projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0da13fa
)
add libphy module to tg3 driver package - fixes unresolved symbols (#4353)
author
Florian Fainelli
<florian@openwrt.org>
Sat, 31 Jan 2009 16:12:41 +0000
(16:12 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sat, 31 Jan 2009 16:12:41 +0000
(16:12 +0000)
SVN-Revision: 14310
package/kernel/modules/netdevices.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/netdevices.mk
b/package/kernel/modules/netdevices.mk
index f16ae8f251d973cc8f9fab4fd18c747e1fe3b8e1..60311b6d57efe9dc3d31e5c187f2bef16144186e 100644
(file)
--- a/
package/kernel/modules/netdevices.mk
+++ b/
package/kernel/modules/netdevices.mk
@@
-254,6
+254,10
@@
define KernelPackage/tg3
DEPENDS:=@LINUX_2_6
SUBMENU:=$(NETWORK_DEVICES_MENU)
AUTOLOAD:=$(call AutoLoad,50,tg3)
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.27)),1)
+ FILES+=$(LINUX_DIR)/drivers/net/phy/libphy.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,40,libphy tg3)
+endif
endef
define KernelPackage/tg3/description