projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d4ce3e8
)
Makefile: ensure that BIN_DIR exists for diffconfig
author
Hannu Nyman
<hannu.nyman@iki.fi>
Fri, 6 Jan 2017 17:51:35 +0000
(19:51 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Sun, 8 Jan 2017 17:50:00 +0000
(18:50 +0100)
Ensure that BIN_DIR exists when the diffconfig target needs it.
Otherwise 'make diffconfig' fails after 'make clean'
Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Makefile
patch
|
blob
|
history
diff --git
a/Makefile
b/Makefile
index 3450f7e2973420ee202b112e7b9b8d4dbbb73123..b220dfd3c56a11f3e27d70e3d6e58cc6448abd2f 100644
(file)
--- a/
Makefile
+++ b/
Makefile
@@
-88,6
+88,7
@@
checksum: FORCE
$(call sha256sums,$(BIN_DIR))
diffconfig: FORCE
+ mkdir -p $(BIN_DIR)
$(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.seed
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)