When openwrt toolchain uses eglibc (2.15) instead of uclibc,
authorMirko Vogt <mirko@openwrt.org>
Mon, 6 Aug 2012 11:08:16 +0000 (11:08 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 6 Aug 2012 11:08:16 +0000 (11:08 +0000)
samba36-server build causes following error:

Package samba36-{client,server} is missing dependencies for the following
libraries:
librt.so.1

Fix is to define
DEPENDS:=+USE_EGLIBC:librt
which adds the librt dependency only if the eglibc is used by toolchain.
Patch tested by building the samba36 both with the the eglibc and uclibc
openwrt toolchains.

Signed-off-by: Mika Laitio <mika.laitio@nokia.com>
SVN-Revision: 33010

net/samba36/Makefile

index 2ebfcbe7f1cfa8e11e4decbcb95c14de76a95a23..edeccc845fd02b27dc06f2dbc40f1ce93cf40b73 100644 (file)
@@ -28,6 +28,7 @@ define Package/samba36-server
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
   URL:=http://www.samba.org/
+  DEPENDS:=+USE_EGLIBC:librt
 endef
 
 define Package/samba36-client
@@ -35,7 +36,7 @@ define Package/samba36-client
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS client
   URL:=http://www.samba.org/
-  DEPENDS:=+libreadline +libncurses
+  DEPENDS:=+libreadline +libncurses +USE_EGLIBC:librt
 endef
 
 define Package/samba36-server/config