projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fc035b3
)
add a prereq check for umask 0022, other settings will result in broken packages
author
Jo-Philipp Wich
<jow@openwrt.org>
Thu, 14 Oct 2010 14:25:29 +0000
(14:25 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Thu, 14 Oct 2010 14:25:29 +0000
(14:25 +0000)
SVN-Revision: 23442
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index 84d3f2274c6b3c8f58cc291018881e4d7f84320c..afb92ff02160473598cfb737a04567e7c9c0b327 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-18,6
+18,13
@@
$(eval $(call Require,non-root, \
Please do not compile as root. \
))
+define Require/umask-0022
+ [ "$$(shell umask)" -eq 22 ]
+endef
+$(eval $(call Require,umask-0022, \
+ Please compile with umask 0022. \
+))
+
# Required for the toolchain
define Require/working-make
$(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null