projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6b87e07
)
include/netfilter.mk: fix kmod-ipt-tee build with 4.3/4.4
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 13 Dec 2015 18:33:11 +0000
(18:33 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 13 Dec 2015 18:33:11 +0000
(18:33 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47890
include/netfilter.mk
patch
|
blob
|
history
diff --git
a/include/netfilter.mk
b/include/netfilter.mk
index 68af50b1df1fb5d00f5c29a3e70c74f561a4d89a..c8e6a8b2399bd87304bfc8e17b053d6262d82f52 100644
(file)
--- a/
include/netfilter.mk
+++ b/
include/netfilter.mk
@@
-255,6
+255,8
@@
$(eval $(call nf_add,IPT_LED,CONFIG_NETFILTER_XT_TARGET_LED, $(P_XT)xt_LED))
# tee
$(eval $(call nf_add,IPT_TEE,CONFIG_NETFILTER_XT_TARGET_TEE, $(P_XT)xt_TEE))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_TEE,CONFIG_NF_DUP_IPV4, $(P_V4)nf_dup_ipv4, ge 4.3),))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_TEE,CONFIG_NF_DUP_IPV6, $(P_V6)nf_dup_ipv6, ge 4.3),))
# u32