squashfs-tools-ng: add package
authorPaul Spooren <mail@aparcar.org>
Sun, 27 Dec 2020 23:02:49 +0000 (13:02 -1000)
committerPaul Spooren <mail@aparcar.org>
Thu, 24 Jun 2021 17:42:38 +0000 (07:42 -1000)
The `squashfs-tools-ng` is a reimplementation of `squashfs-tools` of
which a fork called `squashfskit` is currently used withn OpenWrt.

Signed-off-by: Paul Spooren <mail@aparcar.org>
tools/Makefile
tools/squashfs-tools-ng/Makefile [new file with mode: 0644]

index c9a7547b582e7fbcae4aa45525ded761f19fc441..6c402087a5f95a66bb61e4a292f23812a35926d9 100644 (file)
@@ -70,6 +70,7 @@ $(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compil
 $(curdir)/sdcc/compile := $(curdir)/bison/compile
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
 $(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
+$(curdir)/squashfs-tools-ng/compile := $(curdir)/libtool/compile $(curdir)/xz/compile $(curdir)/zlib/compile
 $(curdir)/zlib/compile := $(curdir)/cmake/compile
 $(curdir)/zstd/compile := $(curdir)/cmake/compile
 
diff --git a/tools/squashfs-tools-ng/Makefile b/tools/squashfs-tools-ng/Makefile
new file mode 100644 (file)
index 0000000..67b856a
--- /dev/null
@@ -0,0 +1,26 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=squashfs-tools-ng
+PKG_VERSION:=1.1.1
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/AgentD/squashfs-tools-ng/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=e4d3dfc9f354267c65bf2dd7e483ad23a148d49b3946e2ab3918e1fbd69015c1
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/.libs/gensquashfs $(STAGING_DIR_HOST)/bin/gensquashfs
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/.libs/tar2sqfs $(STAGING_DIR_HOST)/bin/tar2sqfs
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/.libs/rdsquashfs $(STAGING_DIR_HOST)/bin/rdsquashfs
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/.libs/libsquashfs* $(STAGING_DIR_HOST)/lib/
+endef
+
+define Host/Clean
+endef
+
+$(eval $(call HostBuild))