armsr: use console=tty1 to make console more readily available
authorMark Mentovai <mark@mentovai.com>
Fri, 28 Jun 2024 17:14:59 +0000 (13:14 -0400)
committerRobert Marko <robimarko@gmail.com>
Sun, 25 Aug 2024 11:15:33 +0000 (13:15 +0200)
Like x86, armsr is frequently virtualized, and is used for development
and debugging. Kernel messages should be more readily apparent by
default. This can be achieved by adding console=tty1 to the kernel
command line, enabling the console on a (possibly virtual) display and
keyboard, in addition to a serial port.

This also enables failsafe on tty1. Failsafe mode operates on consoles
known by the kernel, without regard to /etc/inittab.

armsr's /etc/inittab is also updated to specify tty1 instead of tty0.
tty1 is technically more correct: tty1 is the first virtual console,
where tty0 reflects the current active virtual console (which is likely
to be tty1).

This configuration matches x86, which is another target commonly used
for virtualization, development, and debugging in the same way. x86's
kernel command line had specified console=tty0, although console=tty1 is
more correct for the reasons given above. This also brings x86's kernel
command line console= into agreement with its /etc/inittab, which
already used tty1.

Signed-off-by: Mark Mentovai <mark@mentovai.com>
Link: https://github.com/openwrt/openwrt/pull/16213
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/armsr/base-files/etc/inittab
target/linux/armsr/image/Makefile
target/linux/x86/image/Makefile

index b3033a3ced3d4150df365c6484d10afa23e5592f..7ca0231a22bc4080bac6cc6ae391a63fb63ac710 100644 (file)
@@ -2,7 +2,7 @@
 ::shutdown:/etc/init.d/rcS K shutdown
 ttyAMA0::askfirst:/usr/libexec/login.sh
 @GRUB_SERIAL@::askfirst:/usr/libexec/login.sh
-tty0::askfirst:/usr/libexec/login.sh
+tty1::askfirst:/usr/libexec/login.sh
 hvc0::askfirst:/usr/libexec/login.sh
 ttymxc0::askfirst:/usr/libexec/login.sh
 ttymxc1::askfirst:/usr/libexec/login.sh
index 7d04a2e8f6bc4ca7971c3a5992fd3a93f4e196c6..66f027c732f62ae77674b6c1154b54a03b32db68 100644 (file)
@@ -12,6 +12,7 @@ GRUB_TERMINAL_CONFIG =
 GRUB_CONSOLE_CMDLINE = earlycon
 
 ifneq ($(CONFIG_GRUB_CONSOLE),)
+  GRUB_CONSOLE_CMDLINE += console=tty1
   GRUB_TERMINALS += console
 endif
 
index 6e59f2e465f3cb88fdcbee0cdc43f6069545e931..29bebeb7489019df44e956119451614e6f910962 100644 (file)
@@ -12,7 +12,7 @@ GRUB_TERMINAL_CONFIG =
 GRUB_CONSOLE_CMDLINE =
 
 ifneq ($(CONFIG_GRUB_CONSOLE),)
-  GRUB_CONSOLE_CMDLINE += console=tty0
+  GRUB_CONSOLE_CMDLINE += console=tty1
   GRUB_TERMINALS += console
 endif