projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ff46ed4
)
uClibc: fix headers install on prepare with QUILT=1
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 22 Nov 2010 17:50:01 +0000
(17:50 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 22 Nov 2010 17:50:01 +0000
(17:50 +0000)
SVN-Revision: 24100
toolchain/uClibc/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/uClibc/Makefile
b/toolchain/uClibc/Makefile
index 0b6f205380031d63c684785de2569633c19dce83..0df26d097fdf76ca76a9a60aa54bf199eea0d506 100644
(file)
--- a/
toolchain/uClibc/Makefile
+++ b/
toolchain/uClibc/Makefile
@@
-68,6
+68,12
@@
GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
define Host/Prepare
$(call Host/SetToolchainInfo)
$(call Host/Prepare/Default)
+ $(if $(strip $(QUILT)), \
+ cd $(HOST_BUILD_DIR); \
+ if $(QUILT_CMD) next >/dev/null 2>&1; then \
+ $(QUILT_CMD) push -a; \
+ fi
+ )
ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
$(GEN_CONFIG) > $(HOST_BUILD_DIR)/.config
$(SED) 's,^KERNEL_HEADERS=.*,KERNEL_HEADERS=\"$(BUILD_DIR_TOOLCHAIN)/linux-dev/include\",g' \