projects
/
openwrt
/
staging
/
ansuel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8aa91b1
)
hostapd: link against librt if eglibc is used
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 24 Feb 2014 15:03:06 +0000
(15:03 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 24 Feb 2014 15:03:06 +0000
(15:03 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 39741
package/network/services/hostapd/Makefile
patch
|
blob
|
history
diff --git
a/package/network/services/hostapd/Makefile
b/package/network/services/hostapd/Makefile
index f00472ac53a053588532b3a547dfa4feebc3f286..7070afd6ef8193dccf16968540cf65b681f953ef 100644
(file)
--- a/
package/network/services/hostapd/Makefile
+++ b/
package/network/services/hostapd/Makefile
@@
-86,6
+86,10
@@
ifneq ($(LOCAL_TYPE),hostapd)
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif
+ifdef CONFIG_USE_EGLIBC
+ TARGET_LDFLAGS += -lrt
+endif
+
DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!TARGET_avr32||BROKEN)
define Package/hostapd/Default