projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
091897f
)
kernel: kmod-crypto-gf128: Fix build with kernel 6.6
author
Hauke Mehrtens
<hauke@hauke-m.de>
Wed, 13 Mar 2024 19:24:23 +0000
(20:24 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Thu, 14 Mar 2024 19:53:34 +0000
(20:53 +0100)
The gf128mul.ko module was moved in kernel 6.2:
https://git.kernel.org/linus/
61c581a46a9668747d355436bd4b2505594539bd
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index ea2a104335bebc25dacbd077d0944fcc8497bfb9..21b7aa51bd5051177eeb152c9c77e6ec4f063186 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-290,8
+290,12
@@
$(eval $(call KernelPackage,crypto-xcbc))
define KernelPackage/crypto-gf128
TITLE:=GF(2^128) multiplication functions CryptoAPI module
- KCONFIG:=CONFIG_CRYPTO_GF128MUL
- FILES:=$(LINUX_DIR)/crypto/gf128mul.ko
+ KCONFIG:= \
+ CONFIG_CRYPTO_GF128MUL \
+ CONFIG_CRYPTO_LIB_GF128MUL
+ FILES:= \
+ $(LINUX_DIR)/crypto/gf128mul.ko@lt6.2 \
+ $(LINUX_DIR)/lib/crypto/gf128mul.ko@ge6.2
AUTOLOAD:=$(call AutoLoad,09,gf128mul)
$(call AddDepends/crypto)
endef