projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
51aa913
)
mac80211: ath12k: add PCI_SUPPORT dependency
author
Janusz Dziedzic
<janusz.dziedzic@gmail.com>
Tue, 24 Sep 2024 10:21:52 +0000
(12:21 +0200)
committer
Robert Marko
<robimarko@gmail.com>
Tue, 24 Sep 2024 10:27:35 +0000
(12:27 +0200)
Always depend on PCI and don't build on platforms
without PCI.
Signed-off-by: Janusz Dziedzic <janusz.dziedzic@gmail.com>
Link:
https://github.com/openwrt/openwrt/pull/16475
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/mac80211/ath.mk
patch
|
blob
|
history
diff --git
a/package/kernel/mac80211/ath.mk
b/package/kernel/mac80211/ath.mk
index f56fd7a961ccef355caa7d4ddb0c08d709055c57..eecaef4588871ee56eff737d2c5d9ba1c40a5d5a 100644
(file)
--- a/
package/kernel/mac80211/ath.mk
+++ b/
package/kernel/mac80211/ath.mk
@@
-360,7
+360,7
@@
define KernelPackage/ath12k
$(call KernelPackage/mac80211/Default)
TITLE:=Qualcomm 802.11be wireless chipset support
URL:=https://wireless.wiki.kernel.org/en/users/drivers/ath12k
- DEPENDS+= +kmod-ath +@DRIVER_11AC_SUPPORT +@DRIVER_11AX_SUPPORT \
+ DEPENDS+=
@PCI_SUPPORT
+kmod-ath +@DRIVER_11AC_SUPPORT +@DRIVER_11AX_SUPPORT \
+kmod-crypto-michael-mic +kmod-qrtr-mhi \
+kmod-qcom-qmi-helpers
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath12k/ath12k.ko