[packages] fix phidget21 compile by explicitly linking shared objects
authorJohn Crispin <john@openwrt.org>
Thu, 7 Jun 2012 14:55:40 +0000 (14:55 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 7 Jun 2012 14:55:40 +0000 (14:55 +0000)
SVN-Revision: 32108

libs/phidget21/Makefile

index 035ccfb3ba5c5c352be5b75fca70e7b4c89e2341..ccfd443edc7ab78dc10d362e2378abce48ce4821 100644 (file)
@@ -58,7 +58,7 @@ define Build/Compile
                phidget21internal.h
        $(MAKE) -C $(PKG_BUILD_DIR)/webservice \
                $(TARGET_CONFIGURE_OPTS) LDCONFIG="true" \
-               LIBS="-lphidget21 -L../phidget21" \
+               LIBS="-lphidget21 -lpthread -ldl -L../phidget21" \
                CFLAGS="$(TARGET_CFLAGS) -static -D_LINUX -I. -I../phidget21 -I../phidget21/utils" \
                webservice21
 endef