projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0362ccb
)
add a hack to allow source package names in Build-Depends: (PKG_BUILDDEP)
author
Nicolas Thill
<nico@openwrt.org>
Wed, 10 Jan 2007 11:59:42 +0000
(11:59 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Wed, 10 Jan 2007 11:59:42 +0000
(11:59 +0000)
SVN-Revision: 6060
scripts/gen_deps.pl
patch
|
blob
|
history
diff --git
a/scripts/gen_deps.pl
b/scripts/gen_deps.pl
index af206f004782675832ea7f2866232a5f704e65b5..0fc80aae8508154ddc8dfdb02e40c48e75a425d9 100755
(executable)
--- a/
scripts/gen_deps.pl
+++ b/
scripts/gen_deps.pl
@@
-28,6
+28,8
@@
while ($line = <>) {
$line =~ /^Source-Makefile: \s*(.+\/([^\/]+)\/Makefile)\s*$/ and do {
$makefile = $1;
$src = $2;
+ defined $pkg{$src} or $pkg{$src} = {};
+ $pkg{$src}->{src} = $src;
};
$line =~ /^Package: \s*(.+)\s*$/ and do {
$name = $1;