opennhrp: merge r27740, r28324, r28339, r28914
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 15:46:58 +0000 (15:46 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 15:46:58 +0000 (15:46 +0000)
SVN-Revision: 30232

net/opennhrp/Makefile
net/opennhrp/files/opennhrp.init
net/opennhrp/patches/100-compile-fix.patch [deleted file]

index ef9412972c9315db100e3a12d0a03a605c1b9ba3..880803ce7f1b3f21f5fa57d961008076658f9e30 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 # Copyright (C) 2009 Jakob Pfeiffer
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opennhrp
-PKG_VERSION:=0.11.3
-PKG_RELEASE:=1
+PKG_VERSION:=0.12.3
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/opennhrp
-PKG_MD5SUM:=6f6f8571ccc0a9f97e52c6240fe9002a
+PKG_MD5SUM:=4d0ec7c0282e181ecca4d78e52067da3
 
 PKG_FIXUP:=libtool
 PKG_BUILD_PARALLEL:=1
@@ -27,6 +27,7 @@ define Package/opennhrp
   CATEGORY:=Network
   SUBMENU:=VPN
   DEPENDS:=+libcares +ipsec-tools +ip +kmod-gre
+  KCONFIG:=CONFIG_ARPD=y
   TITLE:=NBMA Next Hop Resolution Protocol
   URL:=http://opennhrp.sourceforge.net/
 endef
@@ -48,6 +49,7 @@ define Package/opennhrp/install
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp.conf $(1)/etc/opennhrp/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp-script $(1)/etc/opennhrp/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1down.sh $(1)/etc/opennhrp/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1dead.sh $(1)/etc/opennhrp/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/opennhrp.init $(1)/etc/init.d/opennhrp
 endef
index 706e0181cb5b16b38c6316d701598bd29ab6f410..8831287ea80a025777bedff357d6ce667ea9299f 100755 (executable)
@@ -1,13 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2009 OpenWrt.org
-START=50
+# Copyright (C) 2009-2011 OpenWrt.org
 # Copyright (C) 2009 Jakob Pfeiffer
 
+START=50
+
+SERVICE_USE_PID=1
+
 start() {
-       /usr/sbin/opennhrp -d
+       service_start /usr/sbin/opennhrp -d
 }
 
 stop() {
-       killall opennhrp
+       service_stop /usr/sbin/opennhrp
 }
-
diff --git a/net/opennhrp/patches/100-compile-fix.patch b/net/opennhrp/patches/100-compile-fix.patch
deleted file mode 100644 (file)
index f822feb..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
----
- nhrp/sysdep_netlink.c |    1 +
- 1 file changed, 1 insertion(+)
-
---- opennhrp-0.11.3.orig/nhrp/sysdep_netlink.c
-+++ opennhrp-0.11.3/nhrp/sysdep_netlink.c
-@@ -26,6 +26,7 @@
- #include <asm/types.h>
- #include <linux/netlink.h>
- #include <linux/rtnetlink.h>
-+#include <linux/in6.h>
- #include <linux/ip.h>
- #include <linux/if_arp.h>
- #include <linux/if_tunnel.h>