prereq-build: add Python 3.12 support
authorPaul Spooren <mail@aparcar.org>
Sat, 17 Aug 2024 14:23:54 +0000 (16:23 +0200)
committerRobert Marko <robimarko@gmail.com>
Wed, 16 Oct 2024 20:36:43 +0000 (22:36 +0200)
This reverts commit 09b7e1955c92e0b05197174b7bd4aef2c4073a35.

Signed-off-by: Paul Spooren <mail@aparcar.org>
Link: https://github.com/openwrt/openwrt/pull/16699
Signed-off-by: Robert Marko <robimarko@gmail.com>
include/prereq-build.mk

index 49340ce3e441ccbaa1833d6eb38d8abd450f627e..2378f5ad90c961472f8751f2d116f9978d976b7d 100644 (file)
@@ -182,6 +182,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
+       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
@@ -190,6 +191,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
        python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
+       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \