projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f5e33b9
)
build: ASLR hardening use $(FPIC)
author
Kevin Darbyshire-Bryant
<ldir@darbyshire-bryant.me.uk>
Sat, 9 Jun 2018 08:11:24 +0000
(09:11 +0100)
committer
Jo-Philipp Wich
<jo@mein.io>
Tue, 18 Dec 2018 08:44:04 +0000
(09:44 +0100)
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
(backported from
89b59994eb44b5cd2fac594144c20c63fd05ef25
)
include/hardening.mk
patch
|
blob
|
history
diff --git
a/include/hardening.mk
b/include/hardening.mk
index 06a61789ef6bcc75bcbd6322bb71538a72f7199f..42ce1f56b5a67636d399d6b58ec9125b37134cb9 100644
(file)
--- a/
include/hardening.mk
+++ b/
include/hardening.mk
@@
-18,7
+18,7
@@
ifdef CONFIG_PKG_CHECK_FORMAT_SECURITY
endif
ifdef CONFIG_PKG_ASLR_PIE
ifeq ($(strip $(PKG_ASLR_PIE)),1)
- TARGET_CFLAGS +=
-fPIC
+ TARGET_CFLAGS +=
$(FPIC)
TARGET_LDFLAGS += -specs=$(INCLUDE_DIR)/hardened-ld-pie.specs
endif
endif