projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a14d43d
)
add endian override for mips (big-endian) arch
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 17 Oct 2005 13:03:22 +0000
(13:03 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 17 Oct 2005 13:03:22 +0000
(13:03 +0000)
SVN-Revision: 2134
openwrt/package/libnet/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/package/libnet/Makefile
b/openwrt/package/libnet/Makefile
index 97b228e98f74f4aee36af3f7035232c8a0aa6ac4..1673c0de1cdd7b9b2e3b850b909ae29d33cfe855 100644
(file)
--- a/
openwrt/package/libnet/Makefile
+++ b/
openwrt/package/libnet/Makefile
@@
-16,6
+16,11
@@
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
+ENDIAN:=lil
+ifeq ($(ARCH),mips)
+ENDIAN:=big
+endif
+
$(eval $(call PKG_template,LIBNET,libnet,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
@@
-31,7
+36,7
@@
$(PKG_BUILD_DIR)/.configured:
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
ac_libnet_have_pf_packet=yes \
ac_cv_lbl_unaligned_fail=no \
- ac_cv_libnet_endianess=
lil
\
+ ac_cv_libnet_endianess=
$(ENDIAN)
\
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \