include: meson.mk: honor CONFIG_DEBUG
authorDaniel Golle <daniel@makrotopia.org>
Sat, 9 Nov 2024 23:32:05 +0000 (00:32 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 12 Nov 2024 02:31:06 +0000 (02:31 +0000)
Set buildtype according to CONFIG_DEBUG.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/meson.mk

index 2a20c2bd6bd04ef7164d2564591ced8e3fcd7bc0..ff452d8b01fa4cd29ad0eea080aa64a2fe546833 100644 (file)
@@ -124,7 +124,7 @@ define Build/Configure/Meson
        $(call Meson/CreateCrossFile,$(PKG_BUILD_DIR)/openwrt-cross.txt)
        $(call Meson, \
                setup \
-               --buildtype plain \
+               --buildtype $(if $(CONFIG_DEBUG),debug,plain) \
                --native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
                --cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \
                -Ddefault_library=both \