modify Makefile to avoid patching the install paths, adjust desktop files, workaround...
authorMirko Vogt <mirko@openwrt.org>
Sat, 24 Jan 2009 01:52:00 +0000 (01:52 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 24 Jan 2009 01:52:00 +0000 (01:52 +0000)
SVN-Revision: 14165

phone/paroli/Makefile
phone/paroli/files/paroli.init
phone/paroli/patches/000-change-paths.patch [deleted file]
phone/paroli/patches/050-adjust-desktop-files.patch [new file with mode: 0644]
phone/paroli/patches/100-workaround-bugs.patch [new file with mode: 0644]

index ee66fd88f0e787469d9eb84fe4054e9f28f79b98..83d0d83c77bafa18a67d9177c0f72b215c8eff04 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=paroli
-PKG_VERSION:=20090112
-PKG_REV:=81db9c1a2abd7d56300867b04d4c541e34bb8165
+PKG_VERSION:=20090121
+PKG_REV:=9279b50ed72a94100d7f0f49090043134302f2eb
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -27,10 +27,16 @@ define Package/paroli
   SECTION:=phone
   CATEGORY:=Phone
   TITLE:=integrated phone application
-  DEPENDS:=python-core +fso
+  DEPENDS:=python-core +fso +python-evas +python-ecore +python-edje +python-e_dbus +python-etk
   URL:=http://wiki.openmoko.org/wiki/Paroli
 endef
 
+COMPONENTS:= \
+       paroli-dialer \
+       paroli-contacts \
+       paroli-i-o \
+       paroli-msgs \
+
 define Package/paroli/description
   Paroli is an integrated phone application written in Python which uses the FSO (freesmartphone.org) DBus API
 endef
@@ -41,7 +47,7 @@ define Build/Compile
 endef
 
 define Package/paroli/install
-       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR) $(1)/usr/bin $(1)/etc/init.d $(1)/usr/share/applications/paroli $(1)/usr/share/paroli
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR) $(1)/usr/bin $(1)/etc/init.d $(1)/usr/share/applications/paroli $(1)/usr/share/paroli/services $(1)/usr/share/icons/paroli $(1)/etc/xdg/autostart
        $(CP) \
                $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
                $(1)$(PYTHON_PKG_DIR)
@@ -49,14 +55,25 @@ define Package/paroli/install
                $(PKG_INSTALL_DIR)/usr/bin/* \
                $(1)/usr/bin/
        $(INSTALL_BIN) ./files/paroli.init $(1)/etc/init.d/paroli
+       $(foreach c, $(COMPONENTS), \
+               $(INSTALL_DIR) $(1)/usr/share/paroli/applications/$(c)
+               $(CP) $(PKG_INSTALL_DIR)/../usr/share/paroli/applications/$(c)/$(c).{py,edj} $(1)/usr/share/paroli/applications/$(c)/
+               $(CP) $(PKG_INSTALL_DIR)/../usr/share/paroli/applications/$(c)/icon.png $(1)/usr/share/icons/paroli/$(c).png
+       )
+       $(CP) \
+               $(PKG_INSTALL_DIR)/../usr/share/paroli/services/* \
+               $(1)/usr/share/paroli/services/
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/paroli/* \
-               $(1)/usr/share/paroli/
+               $(PKG_INSTALL_DIR)/../data/tichy \
+               $(1)/usr/share/icons/paroli/tichy.png
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/applications/* \
+               $(PKG_INSTALL_DIR)/usr/applications/*.desktop \
                $(1)/usr/share/applications/paroli/
        $(CP) \
-               $(PKG_INSTALL_DIR)/etc/* \
+               $(PKG_INSTALL_DIR)/usr/applications/paroli-launcher.desktop \
+               $(1)/etc/xdg/autostart/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/../etc/* \
                $(1)/etc/
 endef
 
index b97b882785b7a2c6c1ca411edfb61735d206f6f8..0bbc58a97fb15caeb85be42e858414d8915a81a0 100644 (file)
@@ -3,7 +3,7 @@
 START=99
 
 start() {
-    (sleep 10 && DISPLAY=":0" LD_PRELOAD=/usr/lib/libX11.so /usr/bin/paroli-launcher) & # sleep to wait until the xserver is started | LD_PRELOAD to workaround some runtime linking problems - needs to be fixed
+    (sleep 60 && DISPLAY=":0" LD_PRELOAD=/usr/lib/libX11.so /usr/bin/paroli-launcher) & # sleep to wait until the xserver is started | LD_PRELOAD to workaround some runtime linking problems - needs to be fixed
 }
     
 stop() {
diff --git a/phone/paroli/patches/000-change-paths.patch b/phone/paroli/patches/000-change-paths.patch
deleted file mode 100644 (file)
index 4e0e223..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ruN paroli-20090104.orig/setup.py paroli-20090104/setup.py
---- paroli-20090104.orig/setup.py      2009-01-05 08:38:30.000000000 +0100
-+++ paroli-20090104/setup.py   2009-01-05 08:45:09.000000000 +0100
-@@ -74,7 +74,7 @@
- dbus_data = [
-     (os.path.join(sys.prefix, 'share/dbus-1/system-services/'),
-      ['data/dbus/org.tichy.launcher.service']),
--    ('../../etc/dbus-1/system.d/',
-+    ('../etc/dbus-1/system.d/',
-      ['data/dbus/tichy.conf'])]
- setup(name='Paroli',
-@@ -94,7 +94,7 @@
-                       'data/paroli-dialer.desktop']),
-                     (os.path.join(sys.prefix, 'share/pixmaps/'),
-                      ['data/tichy']),
--                    ('../../etc/paroli/', ['data/paroli.cfg'])] \
-+                    ('../etc/paroli/', ['data/paroli.cfg'])] \
-           + plugins_files('paroli-services', 'paroli/services') \
-           + plugins_files('paroli-applications', 'paroli/applications') \
-           + dbus_data,
diff --git a/phone/paroli/patches/050-adjust-desktop-files.patch b/phone/paroli/patches/050-adjust-desktop-files.patch
new file mode 100644 (file)
index 0000000..9d4e55e
--- /dev/null
@@ -0,0 +1,121 @@
+diff -ruN paroli/data/paroli-contacts.desktop paroli.mod/data/paroli-contacts.desktop
+--- paroli/data/paroli-contacts.desktop        2009-01-23 13:35:16.000000000 +0100
++++ paroli.mod/data/paroli-contacts.desktop    2009-01-23 13:33:12.000000000 +0100
+@@ -1,16 +1,13 @@
+ [Desktop Entry]
+-Name=People
+-Name[fr]=Calculatrice
+-Name[it]=Calcolatrice
+-Name[ru]=Калькулятор
+-Name[sv]=Miniräknare
++GenericName=Contacts
++Name=Contacts
+ Encoding=UTF-8
+ Version=1.0
+-Comment=Paroli Dialer
++Comment=Paroli Contacts
+ StartupNotify=false
+ Exec=dbus-send --system --print-reply --dest=org.tichy.launcher /Launcher org.tichy.Launcher.Launch string:Paroli-Contacts
+-Icon=openmoko-calculator
+-Terminal=true
++Icon=paroli-contacts.png
++Terminal=false
+ Type=Application
+ SingleInstance=true
+-Categories=GTK;Application;Office;
+\ No newline at end of file
++Categories=Telephony;TelephonyTools
+diff -ruN paroli/data/paroli-dialer.desktop paroli.mod/data/paroli-dialer.desktop
+--- paroli/data/paroli-dialer.desktop  2009-01-23 13:35:16.000000000 +0100
++++ paroli.mod/data/paroli-dialer.desktop      2009-01-23 13:33:24.000000000 +0100
+@@ -1,16 +1,13 @@
+ [Desktop Entry]
+-Name=Tele
+-Name[fr]=Calculatrice
+-Name[it]=Calcolatrice
+-Name[ru]=Калькулятор
+-Name[sv]=Miniräknare
++GenericName=Dialer
++Name=Dialer
+ Encoding=UTF-8
+ Version=1.0
+ Comment=Paroli Dialer
+ StartupNotify=false
+ Exec=dbus-send --system --print-reply --dest=org.tichy.launcher /Launcher org.tichy.Launcher.Launch string:Paroli-Dialer
+-Icon=openmoko-calculator
+-Terminal=true
++Icon=paroli-dialer.png
++Terminal=false
+ Type=Application
+ SingleInstance=true
+-Categories=GTK;Application;Office;
+\ No newline at end of file
++Categories=Telephony;TelephonyTools
+diff -ruN paroli/data/paroli-io.desktop paroli.mod/data/paroli-io.desktop
+--- paroli/data/paroli-io.desktop      2009-01-23 13:35:16.000000000 +0100
++++ paroli.mod/data/paroli-io.desktop  2009-01-23 13:33:33.000000000 +0100
+@@ -1,16 +1,13 @@
+ [Desktop Entry]
++GenericName=I/O
+ Name=I/O
+-Name[fr]=Calculatrice
+-Name[it]=Calcolatrice
+-Name[ru]=Калькулятор
+-Name[sv]=Miniräknare
+ Encoding=UTF-8
+ Version=1.0
+ Comment=Paroli I/O
+ StartupNotify=false
+ Exec=dbus-send --system --print-reply --dest=org.tichy.launcher /Launcher org.tichy.Launcher.Launch string:Paroli-I/O
+-Icon=openmoko-calculator
+-Terminal=true
++Icon=paroli-i-o.png
++Terminal=false
+ Type=Application
+ SingleInstance=true
+-Categories=GTK;Application;Office;
+\ No newline at end of file
++Categories=Telephony;TelephonyTools
+diff -ruN paroli/data/paroli-launcher.desktop paroli.mod/data/paroli-launcher.desktop
+--- paroli/data/paroli-launcher.desktop        2009-01-23 13:35:16.000000000 +0100
++++ paroli.mod/data/paroli-launcher.desktop    2009-01-23 13:33:50.000000000 +0100
+@@ -1,11 +1,11 @@
+ [Desktop Entry]
+ Name=PLauncher
+ TryExec=paroli-launcher
+-Icon=tichy
++Icon=tichy.png
+ GenericName=paroli-launcher
+ Comment=Paroli Launcher
+ StartupNotify=false
+ Exec=paroli-launcher
+ Terminal=false
+ Type=Application
+-Categories=Office;
++Categories=Telephony;TelephonyTools
+diff -ruN paroli/data/paroli-msgs.desktop paroli.mod/data/paroli-msgs.desktop
+--- paroli/data/paroli-msgs.desktop    2009-01-23 13:35:16.000000000 +0100
++++ paroli.mod/data/paroli-msgs.desktop        2009-01-23 13:37:18.000000000 +0100
+@@ -1,16 +1,13 @@
+ [Desktop Entry]
+-Name=Msgs
+-Name[fr]=Calculatrice
+-Name[it]=Calcolatrice
+-Name[ru]=Калькулятор
+-Name[sv]=Miniräknare
++GenericName=Messages
++Name=Messages
+ Encoding=UTF-8
+ Version=1.0
+ Comment=Paroli Messages
+ StartupNotify=false
+ Exec=dbus-send --system --print-reply --dest=org.tichy.launcher /Launcher org.tichy.Launcher.Launch string:Paroli-Msgs
+-Icon=openmoko-calculator
+-Terminal=true
++Icon=paroli-msgs.png
++Terminal=false
+ Type=Application
+ SingleInstance=true
+-Categories=GTK;Application;Office;
+\ No newline at end of file
++Categories=Telephony;TelephonyTools
diff --git a/phone/paroli/patches/100-workaround-bugs.patch b/phone/paroli/patches/100-workaround-bugs.patch
new file mode 100644 (file)
index 0000000..23bcbc5
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ruN paroli-20090112.orig/data/paroli-launcher.desktop paroli-20090112/data/paroli-launcher.desktop
+--- paroli-20090112.orig/data/paroli-launcher.desktop  2009-01-17 05:05:49.000000000 +0100
++++ paroli-20090112/data/paroli-launcher.desktop       2009-01-20 21:20:35.000000000 +0100
+@@ -5,7 +5,7 @@
+ GenericName=paroli-launcher
+ Comment=Paroli Launcher
+ StartupNotify=false
+-Exec=paroli-launcher
++Exec=sleep 60 && DISPLAY=":0" LD_PRELOAD=/usr/lib/libX11.so paroli-launcher
+ Terminal=false
+ Type=Application
+ Categories=Telephony;TelephonyTools;