Complain and exit if the user's kernel was built with
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Sun, 16 Nov 2008 22:38:57 +0000 (14:38 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Sun, 16 Nov 2008 22:38:57 +0000 (14:38 -0800)
cfg80211 built into the kernel, we require it be built
as a module.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk

index 740e20475d770acd4bfb6aa4bad1652415dfa17f..4f5a6b982604609419b83e81e9930a42911d0e7d 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -31,6 +31,10 @@ ifeq ($(shell test $(KERNEL_SUBLEVEL) -lt 27 && echo yes),yes)
 $(error "ERROR: You should use compat-wireless-2.6-old for older kernels, this one is for kenrels >= 2.6.27")
 endif
 
+ifeq ($(CONFIG_CFG80211),y)
+$(error "ERROR: your kernel has CONFIG_CFG80211=y, you should have it CONFIG_CFG80211=m if you want to use this thing.")
+endif
+
 # 2.6.27 has FTRACE_DYNAMIC borked, so we will complain if
 # you have it enabled, otherwise you will very likely run into
 # a kernel panic.