Add bahamut IRC server
authorFlorian Fainelli <florian@openwrt.org>
Fri, 4 Apr 2008 18:58:54 +0000 (18:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 4 Apr 2008 18:58:54 +0000 (18:58 +0000)
SVN-Revision: 10731

net/bahamut/Makefile [new file with mode: 0644]
net/bahamut/patches/001-cross_compile.patch [new file with mode: 0644]

diff --git a/net/bahamut/Makefile b/net/bahamut/Makefile
new file mode 100644 (file)
index 0000000..a93a050
--- /dev/null
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bahamut
+PKG_VERSION:=1.8.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=2e782fe99656433ca24f6a9832d9aad5
+
+PKG_SOURCE_URL:=http://bahamut.dal.net/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-release.tar.gz
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bahamut
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libopenssl +zlib
+  TITLE:=Bahamut IRC server
+  URL:=http://bahamut.dal.net
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default,\
+               --with-maxconnections=64 \
+               --with-openssl="$(STAGING_DIR)/usr/lib" \
+               ,\
+               ac_cv_func_dn_skipname=yes \
+       )
+endef
+
+define Build/Compile
+       $(call Build/Compile/Default,\
+               prefix="$(PKG_INSTALL_DIR)/usr" \
+               INSTALL_DIR="$(PKG_INSTALL_DIR)" \
+               STAGING_DIR="$(STAGING_DIR)" \
+               all \
+       )
+endef
+
+define Package/bahamut/install 
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ircd $(1)/usr/sbin
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/doc/*.{txt,conf} $(1)/etc/$(PKG_NAME)
+endef
+
+$(eval $(call BuildPackage,bahamut))
diff --git a/net/bahamut/patches/001-cross_compile.patch b/net/bahamut/patches/001-cross_compile.patch
new file mode 100644 (file)
index 0000000..54d7382
--- /dev/null
@@ -0,0 +1,87 @@
+diff -urN bahamut-1.8.3/configure bahamut-1.8.3.new/configure
+--- bahamut-1.8.3/configure    2004-09-28 08:44:22.000000000 +0200
++++ bahamut-1.8.3.new/configure        2006-04-02 19:37:57.000000000 +0200
+@@ -6197,8 +6197,7 @@
+   { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+ See \`config.log' for more details." >&5
+ echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&2;} }
+ else
+   cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+diff -urN bahamut-1.8.3/Makefile.in bahamut-1.8.3.new/Makefile.in
+--- bahamut-1.8.3/Makefile.in  2004-08-10 03:27:03.000000000 +0200
++++ bahamut-1.8.3.new/Makefile.in      2006-04-02 21:57:43.000000000 +0200
+@@ -23,8 +23,8 @@
+ ENGINE=@SENGINE@
+ SHELL=/bin/sh
+-SUBDIRS=zlib src doc tools
+-INSTDIRS=src doc tools
++SUBDIRS=src
++INSTDIRS=src doc
+ CLEANSUBDIRS=src tools
+ CC=@CC@
+diff -urN bahamut-1.8.3/src/Makefile.in bahamut-1.8.3.new/src/Makefile.in
+--- bahamut-1.8.3/src/Makefile.in      2004-09-24 06:24:10.000000000 +0200
++++ bahamut-1.8.3.new/src/Makefile.in  2006-04-02 22:00:34.000000000 +0200
+@@ -1,8 +1,8 @@
+ CC=@CC@
+ RM=@RM@
+ MV=@MV@
+-IRCDLIBS=@LIBS@ ../zlib/libz.a
+-INCLUDEDIR=-I../include
++IRCDLIBS=-lresolv -lz @LIBS@ -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
++INCLUDEDIR=-I../include -I$(STAGING_DIR)/usr/include
+ OPENSSLINC=@SSL_INCLUDES@
+ ENGINE=@SENGINE@
+ CRYPTO=@ENCRYPT_SRC@
+@@ -11,10 +11,10 @@
+ INSTALL_DIR=@INSTALL_DIR@
+ CFLAGS=@CFLAGS@
+-RES_SRC =
++#RES_SRC =
+ #This is only for very old systems that NEED this
+-#RES_SRC = res_mkquery.c res_init.c res_comp.c
++RES_SRC = res_mkquery.c res_init.c res_comp.c
+ SOURCES = blalloc.c bsd.c channel.c clientlist.c clones.c confparse.c \
+           fdlist.c fds.c hash.c hide.c inet_addr.c ircd.c ircsprintf.c list.c \
+@@ -22,7 +22,7 @@
+           modules.c packet.c parse.c pcre.c res.c s_auth.c s_bsd.c s_conf.c \
+           s_debug.c s_err.c s_misc.c s_numeric.c s_serv.c s_user.c sbuf.c \
+           scache.c send.c struct.c support.c throttle.c userban.c whowas.c \
+-          zlink.c \
++          zlink.c $(RES_SRC) \
+           $(ENGINE) $(CRYPTO)
+ OBJECTS = $(SOURCES:.c=.o) version.o
+diff -urN bahamut-1.8.3/src/res_comp.c bahamut-1.8.3.new/src/res_comp.c
+--- bahamut-1.8.3/src/res_comp.c       2001-07-07 00:26:33.000000000 +0200
++++ bahamut-1.8.3.new/src/res_comp.c   2006-04-02 21:56:10.000000000 +0200
+@@ -231,7 +231,7 @@
+  * the first name on the list, not the pointer to the start of the
+  * message.
+  */
+-int staticdn_find(u_char *exp_dn, u_char *msg, u_char **dnptrs, 
++static int dn_find(u_char *exp_dn, u_char *msg, u_char **dnptrs, 
+                 u_char **lastdnptr)
+ {
+     u_char *dn, *cp, **cpp;
+diff -urN bahamut-1.8.3/zlib/Makefile.in bahamut-1.8.3.new/zlib/Makefile.in
+--- bahamut-1.8.3/zlib/Makefile.in     2004-08-24 00:57:02.000000000 +0200
++++ bahamut-1.8.3.new/zlib/Makefile.in 2006-04-02 19:38:11.000000000 +0200
+@@ -70,7 +70,7 @@
+       fi
+ libz.a: $(OBJS) $(OBJA)
+-      $(AR) $@ $(OBJS) $(OBJA)
++      $(AR) rcv $@ $(OBJS) $(OBJA)
+       -@ ($(RANLIB) $@ || true) >/dev/null 2>&1
+ match.o: match.S