projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
eb7c162
)
include: add a no dict version of lzma to new image build code
author
John Crispin
<john@openwrt.org>
Tue, 26 Apr 2016 11:43:24 +0000
(11:43 +0000)
committer
John Crispin
<john@openwrt.org>
Tue, 26 Apr 2016 11:43:24 +0000
(11:43 +0000)
Required to compress kernels in a brnboot compatible way.
Signed-off-by: Mathias Kresin <openwrt@kresin.me>
SVN-Revision: 49240
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 7c11aa1c13849e0fce4ffdbdaf76711681c99e2f..bc383e6ba81c783518fe4bb24308e8942b90e64d 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-336,7
+336,11
@@
define Build/fit
endef
define Build/lzma
- $(STAGING_DIR_HOST)/bin/lzma e $@ -lc1 -lp2 -pb2 $(1) $@.new
+ $(call Build/lzma-no-dict,-lc1 -lp2 -pb2 $(1))
+endef
+
+define Build/lzma-no-dict
+ $(STAGING_DIR_HOST)/bin/lzma e $@ $(1) $@.new
@mv $@.new $@
endef