projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
89f57c4
)
allow comment lines in the image builder
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 19 Nov 2005 14:35:18 +0000
(14:35 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 19 Nov 2005 14:35:18 +0000
(14:35 +0000)
SVN-Revision: 2535
openwrt/target/linux/imagebuilder/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/target/linux/imagebuilder/Makefile
b/openwrt/target/linux/imagebuilder/Makefile
index c70fb11e93dd4e15f21914d7ecf0c6b8e4cb4050..0ec71199c7eae3e145997019193c341375b27fb5 100644
(file)
--- a/
openwrt/target/linux/imagebuilder/Makefile
+++ b/
openwrt/target/linux/imagebuilder/Makefile
@@
-36,7
+36,7
@@
build:
mkdir -p $(LINUX_BUILD_DIR)/root
echo -e 'dest root /\noption offline_root $(LINUX_BUILD_DIR)/root' > $(LINUX_BUILD_DIR)/ipkg.conf
$(IPKG_KERNEL) install $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/kernel[-_]*.ipk
- for package in `
cat
lists/$(LIST).$(BOARD)-$(KERNEL)`; do \
+ for package in `
grep -v '^#'
lists/$(LIST).$(BOARD)-$(KERNEL)`; do \
$(IPKG_KERNEL) install `ls packages/$${package}_*`; \
done
if [ -d ./files ]; then \