projects
/
openwrt
/
staging
/
adrian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f3921ac
)
kernel: iscsi-initator: fix missing dependency
author
Petr Štetiar
<ynezz@true.cz>
Wed, 8 Jul 2020 19:11:40 +0000
(21:11 +0200)
committer
Petr Štetiar
<ynezz@true.cz>
Wed, 8 Jul 2020 19:13:14 +0000
(21:13 +0200)
Fixes following issue:
Package kmod-iscsi-initiator is missing dependencies for the following libraries:
crypto_hash.ko
Fixes: b88f8202c4ce ("kernel: add iscsi-initator support")
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/linux/modules/block.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/block.mk
b/package/kernel/linux/modules/block.mk
index a86c60da2acf237ad9a3a7b709f61a464a1c57a7..faea5cc34ef745def17cf7a12c93230a22e0cead 100644
(file)
--- a/
package/kernel/linux/modules/block.mk
+++ b/
package/kernel/linux/modules/block.mk
@@
-273,7
+273,7
@@
$(eval $(call KernelPackage,dm-raid))
define KernelPackage/iscsi-initiator
SUBMENU:=$(BLOCK_MENU)
TITLE:=iSCSI Initiator over TCP/IP
- DEPENDS:=+kmod-scsi-core
+ DEPENDS:=+kmod-scsi-core
+kmod-crypto-hash
KCONFIG:= \
CONFIG_INET \
CONFIG_SCSI_LOWLEVEL \