projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
34a8300
)
fix up TMPDIR for initial prereq check to avoid creating a bogus build_ directory
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 21 Aug 2006 23:13:17 +0000
(23:13 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 21 Aug 2006 23:13:17 +0000
(23:13 +0000)
SVN-Revision: 4617
openwrt/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/Makefile
b/openwrt/Makefile
index 5b90c482f0a657420986e1eb3d15762af22ba8b6..15074c58c3afe66f3bcccea05a5c13a116c5899b 100644
(file)
--- a/
openwrt/Makefile
+++ b/
openwrt/Makefile
@@
-96,10
+96,11
@@
toolchain/%: FORCE
@touch $@
.prereq-packages: include/prereq.mk .pkginfo .config
- @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+ @$(NO_TRACE_MAKE) -s -C package
TMPDIR="$(TOPDIR)/tmp"
prereq 2>/dev/null || { \
echo "Prerequisite check failed. Use FORCE=1 to override."; \
false; \
}
+ rm -rf "$(TOPDIR)/tmp"
@touch $@
prereq: .prereq-build .prereq-packages FORCE