darkstat: fix DNS resolution on uClibc (#12323)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 15 Jul 2013 20:50:55 +0000 (20:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 15 Jul 2013 20:50:55 +0000 (20:50 +0000)
SVN-Revision: 37351

net/darkstat/Makefile
net/darkstat/patches/100-do-not-use-NI_IDN.patch [new file with mode: 0644]

index f0013c9a7c8bb70f5dc6e6de86dde8e9b79da69a..00e4da6acf9dd325a7824e0d0d8b72593819f364 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=darkstat
 PKG_VERSION:=3.0.715
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://unix4lyfe.org/darkstat
diff --git a/net/darkstat/patches/100-do-not-use-NI_IDN.patch b/net/darkstat/patches/100-do-not-use-NI_IDN.patch
new file mode 100644 (file)
index 0000000..35133a3
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/dns.c
++++ b/dns.c
+@@ -346,9 +346,6 @@ dns_main(void)
+          reply.addr = ip;
+          flags = NI_NAMEREQD;
+-#  ifdef NI_IDN
+-         flags |= NI_IDN;
+-#  endif
+          switch (ip.family) {
+             case IPv4:
+                sin.sin_family = AF_INET;