[packages] add devmem2
authorClaudio Mignanti <c.mignanti@gmail.com>
Fri, 23 Jul 2010 13:53:05 +0000 (13:53 +0000)
committerClaudio Mignanti <c.mignanti@gmail.com>
Fri, 23 Jul 2010 13:53:05 +0000 (13:53 +0000)
SVN-Revision: 22369

utils/devmem2/Makefile [new file with mode: 0644]
utils/devmem2/src/Makefile [new file with mode: 0644]
utils/devmem2/src/devmem2.c [new file with mode: 0644]

diff --git a/utils/devmem2/Makefile b/utils/devmem2/Makefile
new file mode 100644 (file)
index 0000000..baa1337
--- /dev/null
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=devmem2
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/devmem2
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Simple program to read/write from memory.
+endef
+
+define Package/devmem2/description
+  Simple program to read/write from/to any location in memory.
+endef
+
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/devmem2/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/devmem2 $(1)/usr/sbin/devmem2
+endef
+
+$(eval $(call BuildPackage,devmem2))
diff --git a/utils/devmem2/src/Makefile b/utils/devmem2/src/Makefile
new file mode 100644 (file)
index 0000000..1db49ca
--- /dev/null
@@ -0,0 +1,13 @@
+OBJ = devmem2.o
+
+all: compile
+
+%.o: %.c
+       $(CC) $(CFLAGS) -c -o $@ $<
+
+compile: $(OBJ)
+       $(CC) -o devmem2 $(LDFLAGS) $(OBJ)
+
+clean:
+       rm -f *.o *.so devmem2
+
diff --git a/utils/devmem2/src/devmem2.c b/utils/devmem2/src/devmem2.c
new file mode 100644 (file)
index 0000000..0c1b5b3
--- /dev/null
@@ -0,0 +1,132 @@
+/*
+ * devmem2.c: Simple program to read/write from/to any location in memory.
+ *
+ *  Copyright (C) 2000, Jan-Derk Bakker (J.D.Bakker@its.tudelft.nl)
+ *
+ *
+ * This software has been developed for the LART computing board
+ * (http://www.lart.tudelft.nl/). The development has been sponsored by
+ * the Mobile MultiMedia Communications (http://www.mmc.tudelft.nl/)
+ * and Ubiquitous Communications (http://www.ubicom.tudelft.nl/)
+ * projects.
+ *
+ * The author can be reached at:
+ *
+ *  Jan-Derk Bakker
+ *  Information and Communication Theory Group
+ *  Faculty of Information Technology and Systems
+ *  Delft University of Technology
+ *  P.O. Box 5031
+ *  2600 GA Delft
+ *  The Netherlands
+ *
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+ *
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <unistd.h>
+#include <string.h>
+#include <errno.h>
+#include <signal.h>
+#include <fcntl.h>
+#include <ctype.h>
+#include <termios.h>
+#include <sys/types.h>
+#include <sys/mman.h>
+  
+#define FATAL do { fprintf(stderr, "Error at line %d, file %s (%d) [%s]\n", \
+  __LINE__, __FILE__, errno, strerror(errno)); exit(1); } while(0)
+#define MAP_SIZE 4096UL
+#define MAP_MASK (MAP_SIZE - 1)
+
+int main(int argc, char **argv) {
+       int fd;
+       void *map_base, *virt_addr; 
+       unsigned long read_result, writeval;
+       off_t target;
+       int access_type = 'w';
+       
+       if(argc < 2) {
+               fprintf(stderr, "\nUsage:\t%s { address } [ type [ data ] ]\n"
+                       "\taddress : memory address to act upon\n"
+                       "\ttype : access operation type : [b]yte, [h]alfword, [w]ord\n"
+                       "\tdata : data to be written\n\n",
+                       argv[0]);
+               exit(1);
+       }
+       target = strtoul(argv[1], 0, 0);
+
+       if(argc > 2)
+               access_type = tolower(argv[2][0]);
+
+
+       if((fd = open("/dev/mem", O_RDWR | O_SYNC)) == -1) FATAL;
+       printf("/dev/mem opened.\n"); 
+       fflush(stdout);
+       
+       /* Map one page */
+       map_base = mmap(0, MAP_SIZE, PROT_READ | PROT_WRITE, MAP_SHARED, fd, target & ~MAP_MASK);
+       if(map_base == (void *) -1) FATAL;
+       printf("Memory mapped at address %p.\n", map_base); 
+       fflush(stdout);
+       
+       virt_addr = map_base + (target & MAP_MASK);
+       switch(access_type) {
+               case 'b':
+                       read_result = *((unsigned char *) virt_addr);
+                       break;
+               case 'h':
+                       read_result = *((unsigned short *) virt_addr);
+                       break;
+               case 'w':
+                       read_result = *((unsigned long *) virt_addr);
+                       break;
+               default:
+                       fprintf(stderr, "Illegal data type '%c'.\n", access_type);
+                       exit(2);
+       }
+       printf("Value at address 0x%lX (%p): 0x%lX\n", target, virt_addr, read_result); 
+       fflush(stdout);
+
+       if(argc > 3) {
+               writeval = strtoul(argv[3], 0, 0);
+               switch(access_type) {
+                       case 'b':
+                               *((unsigned char *) virt_addr) = writeval;
+                               read_result = *((unsigned char *) virt_addr);
+                               break;
+                       case 'h':
+                               *((unsigned short *) virt_addr) = writeval;
+                               read_result = *((unsigned short *) virt_addr);
+                               break;
+                       case 'w':
+                               *((unsigned long *) virt_addr) = writeval;
+                               read_result = *((unsigned long *) virt_addr);
+                               break;
+               }
+               printf("Written 0x%lX; readback 0x%lX\n", writeval, read_result); 
+               fflush(stdout);
+       }
+       
+       if(munmap(map_base, MAP_SIZE) == -1) FATAL;
+       close(fd);
+       return 0;
+}
+
+