backports: address nouveau file shuffling
authorLuis R. Rodriguez <mcgrof@do-not-panic.com>
Thu, 16 May 2013 22:30:03 +0000 (15:30 -0700)
committerJohannes Berg <johannes.berg@intel.com>
Fri, 17 May 2013 12:06:27 +0000 (14:06 +0200)
The recent file shuffling on nouveau requires some
changes not upstream to get it to compile to ensure
some objects do get interpreted as requiring the
new search path.

Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
patches/collateral-evolutions/drm/13-nouveau-include-fix/INFO [new file with mode: 0644]
patches/collateral-evolutions/drm/13-nouveau-include-fix/drivers_gpu_drm_nouveau_Makefile.patch [new file with mode: 0644]

diff --git a/patches/collateral-evolutions/drm/13-nouveau-include-fix/INFO b/patches/collateral-evolutions/drm/13-nouveau-include-fix/INFO
new file mode 100644 (file)
index 0000000..9fda4df
--- /dev/null
@@ -0,0 +1,2 @@
+The headers are not being picked up and require
+ensuring we are pointing to our backport selection.
diff --git a/patches/collateral-evolutions/drm/13-nouveau-include-fix/drivers_gpu_drm_nouveau_Makefile.patch b/patches/collateral-evolutions/drm/13-nouveau-include-fix/drivers_gpu_drm_nouveau_Makefile.patch
new file mode 100644 (file)
index 0000000..dace69b
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/drivers/gpu/drm/nouveau/Makefile
++++ b/drivers/gpu/drm/nouveau/Makefile
+@@ -2,7 +2,7 @@
+ # Makefile for the drm device driver.  This driver provides support for the
+ # Direct Rendering Infrastructure (DRI) in XFree86 4.1.0 and higher.
+-ccflags-y := -Iinclude/drm
++ccflags-y += -I$(backport_srctree)/include/drm
+ ccflags-y += -I$(src)/core/include
+ ccflags-y += -I$(src)/core
+ ccflags-y += -I$(src)