projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
eb82b2c
)
ath79: zte-mf28x-common: fix initramfs execution
author
Lech Perczak
<lech.perczak@gmail.com>
Wed, 20 Nov 2024 02:45:46 +0000
(
03:45
+0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Mon, 20 Jan 2025 21:00:02 +0000
(22:00 +0100)
Now that LZMA_TEXT_START is configurable per-target once again,
move the target above 32MB boundary for ZTE MF28* devices.
Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
Link:
https://github.com/openwrt/openwrt/pull/17616
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit
32c6b9064ac7fc62cead37b1bc7d46ffba598c71
)
target/linux/ath79/image/nand.mk
patch
|
blob
|
history
diff --git
a/target/linux/ath79/image/nand.mk
b/target/linux/ath79/image/nand.mk
index d3c1120aa23ca01e173d7d5b676cbcd819b1d253..e8494da15da7e3b8ff8942d117b133eccc69a1c3 100644
(file)
--- a/
target/linux/ath79/image/nand.mk
+++ b/
target/linux/ath79/image/nand.mk
@@
-442,6
+442,10
@@
define Device/zte_mf28x_common
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct
BLOCKSIZE := 128k
PAGESIZE := 2048
+ LOADER_TYPE := bin
+ LZMA_TEXT_START := 0x82800000
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | uImage none
+ KERNEL_INITRAMFS := $$(KERNEL)
KERNEL_SIZE := 4096k
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef