projects
/
openwrt
/
staging
/
neocturne.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
87fe1d3
)
deptest: Check for .config
author
Michael Büsch
<mb@bu3sch.de>
Wed, 3 Nov 2010 00:27:50 +0000
(
00:27
+0000)
committer
Michael Büsch
<mb@bu3sch.de>
Wed, 3 Nov 2010 00:27:50 +0000
(
00:27
+0000)
SVN-Revision: 23810
scripts/deptest.sh
patch
|
blob
|
history
diff --git
a/scripts/deptest.sh
b/scripts/deptest.sh
index ad378bafcd976eccc4c66742ed06141cc3ac755d..3a81659f7b988362196702bece26f78105e50522 100755
(executable)
--- a/
scripts/deptest.sh
+++ b/
scripts/deptest.sh
@@
-22,6
+22,8
@@
die()
[ -f "$BASEDIR/include/toplevel.mk" ] || \
die "Error: Could not find buildsystem base directory"
+[ -f "$BASEDIR/.config" ] || \
+ die "The buildsystem is not configured. Please run make menuconfig."
cd "$BASEDIR" || die "Failed to enter base directory"
mkdir -p "$STAMP_DIR_SUCCESS" "$STAMP_DIR_FAILED" "$BUILD_DIR" "$BUILD_DIR_HOST" "$LOG_DIR"