projects
/
openwrt
/
staging
/
neocturne.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b569d0c
)
include/package-pack: remove APK files before building package
author
Christian Marangi
<ansuelsmth@gmail.com>
Wed, 22 May 2024 17:33:52 +0000
(19:33 +0200)
committer
Christian Marangi
<ansuelsmth@gmail.com>
Tue, 11 Jun 2024 21:58:13 +0000
(23:58 +0200)
As done for OPKG, correctly remove APK files before building package to
make sure we don't work on dirty files.
Link:
https://github.com/openwrt/openwrt/pull/15543
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/package-pack.mk
patch
|
blob
|
history
diff --git
a/include/package-pack.mk
b/include/package-pack.mk
index 16b56344e1d150e47f152c6270c4564f865e6e95..5054e8dc85d95ea501953a645d307ed64b62d6b1 100644
(file)
--- a/
include/package-pack.mk
+++ b/
include/package-pack.mk
@@
-205,6
+205,8
@@
$(_endef)
rm -rf $$(IDIR_$(1))
ifeq ($$(CONFIG_USE_APK),)
$$(call remove_ipkg_files,$(1),$$(call opkg_package_files,$(call gen_package_wildcard,$(1))))
+else
+ $$(call remove_ipkg_files,$(1),$$(call apk_package_files,$(call gen_package_wildcard,$(1))))
endif
mkdir -p $(PACKAGE_DIR) $$(IDIR_$(1)) $(PKG_INFO_DIR)
$(call Package/$(1)/install,$$(IDIR_$(1)))