ptpd: update to 2.1.0 * add new libpthread and librt dependencies * move to time...
authorStephen Walker <stephendwalker@gmail.com>
Fri, 4 Mar 2011 08:37:20 +0000 (08:37 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Fri, 4 Mar 2011 08:37:20 +0000 (08:37 +0000)
SVN-Revision: 25862

net/ptpd/Makefile

index cbccb340bf97821b50dac94c5c330024e49be7e9..41816ce0d10c15e9ed60f2d97cf9f5ef41a88f05 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2010 OpenWrt.org
+#
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ptpd
-PKG_VERSION:=1.0.0
-PKG_RELEASE:=2
+PKG_VERSION:=2.1.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ptpd
-PKG_MD5SUM:=b112b2bedc7f6e6e11a838608b9e0357
+PKG_MD5SUM:=9748f031ed9ebb5c600de354dae53046
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,18 +22,22 @@ MAKE_PATH:=src
 define Package/ptpd
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=Precision Time protocol (PTP) daemon
+  SUBMENU:=Time Synchronization
+  TITLE:=Precision Time Protocol (PTP) daemon
   URL:=http://ptpd.sourceforge.net/
+  DEPENDS:=+libpthread +librt
 endef
 
-define Package/ptpd/daemon
- The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as defined by the IEEE 1588 standard.
- PTP was developed to provide very precise time coordination of LAN connected computers.
+define Package/ptpd/description
+ The PTP daemon (PTPd) implements version 2 of the Precision Time Protocol (PTP)
+ as defined by the IEEE 1588-2008 standard.
+ PTP was developed to provide very precise time coordination of LAN connected
+ computers.
 endef
 
 define Package/ptpd/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptpd2 $(1)/usr/sbin/ptpd
        $(INSTALL_BIN) ./files/ptpd.init $(1)/etc/init.d/ptpd
 endef