projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
994428f
)
include/kernel: sort autoload modules list to fix reproducible builds
author
Alexander Couzens
<lynxis@fe80.eu>
Thu, 28 Feb 2019 15:37:41 +0000
(16:37 +0100)
committer
Alexander Couzens
<lynxis@fe80.eu>
Thu, 28 Feb 2019 16:57:30 +0000
(17:57 +0100)
When autoloading more than one modules per packages,
/etc/modules.d/$module depends on the file system ordering.
To test this: use disorderfs on the build_dir and build kmod-sched.
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
include/kernel.mk
patch
|
blob
|
history
diff --git
a/include/kernel.mk
b/include/kernel.mk
index 19ecf4fa9a849444ef29958fb4011e38d8b7c37f..3195090a0a79795bd4f629fae963c251c6c18a4b 100644
(file)
--- a/
include/kernel.mk
+++ b/
include/kernel.mk
@@
-243,7
+243,7
@@
$(call KernelPackage/$(1)/config)
exit 1; \
fi; \
done;
- $(call ModuleAutoLoad,$(1),$$(1),$(filter-out 0-,$(word 1,$(AUTOLOAD))-),$(filter-out 0,$(word 2,$(AUTOLOAD))),$(
wordlist 3,99,$(AUTOLOAD
)))
+ $(call ModuleAutoLoad,$(1),$$(1),$(filter-out 0-,$(word 1,$(AUTOLOAD))-),$(filter-out 0,$(word 2,$(AUTOLOAD))),$(
sort $(wordlist 3,99,$(AUTOLOAD)
)))
$(call KernelPackage/$(1)/install,$$(1))
endef
$(if $(CONFIG_PACKAGE_kmod-$(1)),