aiccu: Add 'restart' option to force restart of daemon instead of HUP (#7629)
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Thu, 3 Nov 2011 16:05:42 +0000 (16:05 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Thu, 3 Nov 2011 16:05:42 +0000 (16:05 +0000)
SVN-Revision: 28727

ipv6/aiccu/Makefile
ipv6/aiccu/files/aiccu.hotplug
ipv6/aiccu/files/aiccu.init

index 496fce4dcd33d60a53009b3db8a912cfe76b64a1..b2c4f22dd1aef447dc4c9dc0f0edd34ea35cb622 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
 PKG_VERSION:=20070115
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
index b886976210797c5a8e72e17a698f4f99e133609f..5830415a45558e059fa686829ed5a10aaebb5aed 100644 (file)
@@ -1,2 +1,2 @@
 #!/bin/sh
-[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && /etc/init.d/aiccu enabled && /etc/init.d/aiccu start
+[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && /etc/init.d/aiccu enabled && /etc/init.d/aiccu restart
index bc5ef75432e529d53c78d93d11807240d7e6e352..9261db8c7d48a4d0ac015508162c7598ad0db476 100644 (file)
@@ -57,7 +57,8 @@ stop_instance() {
 
 restart_instance() {
        local cfg="$1"
-       stop_instance "$cfg"
+       config_get_bool restart "$cfg" restart 0
+       [ "$restart" -eq 1 ] && stop_instance "$cfg"
        start_instance "$cfg"
 }