mdnsresponder: bump to 544 (thanks Markus Stenberg)
authorSteven Barth <cyrus@openwrt.org>
Mon, 17 Feb 2014 13:32:56 +0000 (13:32 +0000)
committerSteven Barth <cyrus@openwrt.org>
Mon, 17 Feb 2014 13:32:56 +0000 (13:32 +0000)
SVN-Revision: 39603

net/mdnsresponder/Makefile
net/mdnsresponder/files/mdnsd.hotplug [new file with mode: 0644]
net/mdnsresponder/files/mdnsd.init

index 707c20d74ed1ae50a14253b7e86be1bfb8b96361..6e96393b6254d27b79938d8badcf14f3cb8dcb89 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mDNSResponder
-PKG_VERSION:=379.37
-PKG_RELEASE:=2
+PKG_VERSION:=544
+PKG_RELEASE:=1
 
 PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
-PKG_MD5SUM:=dd557e1058b51ac2f29cd01d67be0145
+PKG_MD5SUM:=39142ab70bd82a096801ce346f86cbab
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/mDNSResponder-$(PKG_VERSION)
 
@@ -145,6 +145,8 @@ endef
 define Package/mdnsd/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mdnsd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/mdnsd.hotplug $(1)/etc/hotplug.d/iface
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/mdnsd.init $(1)/etc/init.d/mdnsd
        $(INSTALL_DIR) $(1)/usr/lib/
diff --git a/net/mdnsresponder/files/mdnsd.hotplug b/net/mdnsresponder/files/mdnsd.hotplug
new file mode 100644 (file)
index 0000000..c4e850c
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+/etc/init.d/mdnsd enabled || exit 0
+[ "$ACTION" = ifupdate -a -z "$IFUPDATE_ADDRESSES" ] && exit 0
+logger -t mdnsd "Restarting mdnsd due to $ACTION of $INTERFACE ($DEVICE)"
+/etc/init.d/mdnsd restart
index 6d77f0a2d32229c318812ffc9e6bf3d5994264a7..817604babb89dbf8117aec717473ac08b31142f4 100755 (executable)
@@ -1,14 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 
 START=60
-
-SERVICE_USE_PID=1
-
-start() {
-       service_start /usr/sbin/mdnsd
+STOP=10
+USE_PROCD=1
+
+start_service() {
+    procd_open_instance
+    procd_set_param command /usr/sbin/mdnsd -debug
+    procd_set_param respawn
+    procd_close_instance
 }
 
-stop() {
-       service_stop /usr/sbin/mdnsd
-}