mac80211: update to version 6.11.2
authorFelix Fietkau <nbd@nbd.name>
Fri, 4 Oct 2024 16:43:32 +0000 (18:43 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 4 Oct 2024 17:18:16 +0000 (19:18 +0200)
Adds a number of minor fixes

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mac80211/Makefile
package/kernel/mac80211/patches/ath9k/500-ath9k_eeprom_debugfs.patch
package/kernel/mac80211/patches/ath9k/512-ath9k_channelbw_debugfs.patch
package/kernel/mac80211/patches/ath9k/530-ath9k_extra_leds.patch
package/kernel/mac80211/patches/ath9k/542-ath9k_debugfs_diag.patch
package/kernel/mac80211/patches/brcm/862-brcmfmac-Disable-power-management.patch
package/kernel/mac80211/patches/mwl/801-libertas-configure-sysfs-links.patch
package/kernel/mac80211/patches/mwl/802-libertas-set-wireless-macaddr.patch
package/kernel/mac80211/patches/subsys/320-mac80211-add-AQL-support-for-broadcast-packets.patch
package/kernel/mt76/patches/100-api_update.patch [new file with mode: 0644]

index 026d3e5f8288896fa7b077b8410d1c98faaaefe3..7f1cb7f38fea818bc806203726d215a9617c77db 100644 (file)
@@ -10,13 +10,13 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mac80211
 
-PKG_VERSION:=6.11
+PKG_VERSION:=6.11.2
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0-only
 PKG_LICENSE_FILES:=COPYING
 
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
-PKG_HASH:=2c091ce9520c2e4c8a9c91a294f3c040f90cd76222674928e61542ead06cfa41
+PKG_HASH:=700ea5abef8dde9e3c6df2acd32ff443da735d773d56db9a80269e2237549b34
 
 PKG_SOURCE:=backports-$(PKG_VERSION).tar.xz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(if $(BUILD_VARIANT),$(PKG_NAME)-$(BUILD_VARIANT)/)backports-$(PKG_VERSION)
index a0ec7ef972f023569e9181170e8a9c1288019d96..f1431526bcd17e70846661edcb5ca19c6beb266d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath9k/debug.c
 +++ b/drivers/net/wireless/ath/ath9k/debug.c
-@@ -1431,6 +1431,7 @@ int ath9k_init_debug(struct ath_hw *ah)
+@@ -1429,6 +1429,7 @@ int ath9k_init_debug(struct ath_hw *ah)
  
        ath9k_cmn_debug_base_eeprom(sc->debug.debugfs_phy, sc->sc_ah);
        ath9k_cmn_debug_modal_eeprom(sc->debug.debugfs_phy, sc->sc_ah);
@@ -82,7 +82,7 @@
  void ath9k_cmn_debug_recv(struct dentry *debugfs_phy,
 --- a/drivers/net/wireless/ath/ath9k/htc_drv_debug.c
 +++ b/drivers/net/wireless/ath/ath9k/htc_drv_debug.c
-@@ -514,6 +514,7 @@ int ath9k_htc_init_debug(struct ath_hw *
+@@ -512,6 +512,7 @@ int ath9k_htc_init_debug(struct ath_hw *
  
        ath9k_cmn_debug_base_eeprom(priv->debug.debugfs_phy, priv->ah);
        ath9k_cmn_debug_modal_eeprom(priv->debug.debugfs_phy, priv->ah);
index 72eae8c7d6ea3aa5bfe9430fc80e68cb44289213..87d18626da377927b7bfb200ba9dab9a5d36896f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath9k/debug.c
 +++ b/drivers/net/wireless/ath/ath9k/debug.c
-@@ -1432,6 +1432,7 @@ int ath9k_init_debug(struct ath_hw *ah)
+@@ -1430,6 +1430,7 @@ int ath9k_init_debug(struct ath_hw *ah)
        ath9k_cmn_debug_base_eeprom(sc->debug.debugfs_phy, sc->sc_ah);
        ath9k_cmn_debug_modal_eeprom(sc->debug.debugfs_phy, sc->sc_ah);
        ath9k_cmn_debug_eeprom(sc->debug.debugfs_phy, sc->sc_ah);
 +EXPORT_SYMBOL(ath9k_cmn_debug_chanbw);
 --- a/drivers/net/wireless/ath/ath9k/htc_drv_debug.c
 +++ b/drivers/net/wireless/ath/ath9k/htc_drv_debug.c
-@@ -515,6 +515,7 @@ int ath9k_htc_init_debug(struct ath_hw *
+@@ -513,6 +513,7 @@ int ath9k_htc_init_debug(struct ath_hw *
        ath9k_cmn_debug_base_eeprom(priv->debug.debugfs_phy, priv->ah);
        ath9k_cmn_debug_modal_eeprom(priv->debug.debugfs_phy, priv->ah);
        ath9k_cmn_debug_eeprom(priv->debug.debugfs_phy, priv->ah);
index 71a6dd9f00ab40e1c2887a8c29a7e83366aaf2fd..4bb27d558cc43c6b6582578fc0218cc79f708d53 100644 (file)
  
  static ssize_t read_file_ani(struct file *file, char __user *user_buf,
                             size_t count, loff_t *ppos)
-@@ -1392,6 +1447,10 @@ int ath9k_init_debug(struct ath_hw *ah)
+@@ -1390,6 +1445,10 @@ int ath9k_init_debug(struct ath_hw *ah)
        ath9k_tx99_init_debug(sc);
        ath9k_cmn_spectral_init_debug(&sc->spec_priv, sc->debug.debugfs_phy);
  
index a0e5a24ed8e83065bd59ae353f9d2ab8a0ffb301..f08301c7f4f207f6077e47d5143a7c38b66cc3e1 100644 (file)
@@ -51,7 +51,7 @@
  int ath9k_init_debug(struct ath_hw *ah)
  {
        struct ath_common *common = ath9k_hw_common(ah);
-@@ -1451,6 +1495,8 @@ int ath9k_init_debug(struct ath_hw *ah)
+@@ -1449,6 +1493,8 @@ int ath9k_init_debug(struct ath_hw *ah)
        debugfs_create_file("gpio_led", S_IWUSR,
                           sc->debug.debugfs_phy, sc, &fops_gpio_led);
  #endif
index 9f91b29c400112142c657513b97f700646053004..3472ff6afc6be1802f89a4ab3e59b38c06df5d69 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
 +++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
-@@ -3313,6 +3313,10 @@ brcmf_cfg80211_set_power_mgmt(struct wip
+@@ -3314,6 +3314,10 @@ brcmf_cfg80211_set_power_mgmt(struct wip
         * preference in cfg struct to apply this to
         * FW later while initializing the dongle
         */
index 4d9d3de4655faeb771b996880b3962f06aec50bc..e6111871c047de726d06467c7401550def59a41f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/marvell/libertas/cfg.c
 +++ b/drivers/net/wireless/marvell/libertas/cfg.c
-@@ -2101,6 +2101,8 @@ struct wireless_dev *lbs_cfg_alloc(struc
+@@ -2102,6 +2102,8 @@ struct wireless_dev *lbs_cfg_alloc(struc
                goto err_wiphy_new;
        }
  
index 9aa559979c34b7752d1ad9f600d0c4f593a63a73..97ddd66b324a36fbc5b9655061f10c975271343c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/marvell/libertas/cfg.c
 +++ b/drivers/net/wireless/marvell/libertas/cfg.c
-@@ -2178,6 +2178,8 @@ int lbs_cfg_register(struct lbs_private
+@@ -2179,6 +2179,8 @@ int lbs_cfg_register(struct lbs_private
        wdev->wiphy->n_cipher_suites = ARRAY_SIZE(cipher_suites);
        wdev->wiphy->reg_notifier = lbs_reg_notifier;
  
index 3b6cba48e7150a5f9d38d17304a013c97634cd66..c03f40d9b4f5c2c6d5c65b3f1c645250e3676acb 100644 (file)
@@ -245,7 +245,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                if (iter == txqi)
 --- a/include/net/mac80211.h
 +++ b/include/net/mac80211.h
-@@ -1221,8 +1221,8 @@ struct ieee80211_tx_info {
+@@ -1222,8 +1222,8 @@ struct ieee80211_tx_info {
            status_data_idr:1,
            status_data:13,
            hw_queue:4,
diff --git a/package/kernel/mt76/patches/100-api_update.patch b/package/kernel/mt76/patches/100-api_update.patch
new file mode 100644 (file)
index 0000000..8b528f0
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/tx.c
++++ b/tx.c
+@@ -350,7 +350,7 @@ mt76_tx(struct mt76_phy *phy, struct iee
+       info->hw_queue |= FIELD_PREP(MT_TX_HW_QUEUE_PHY, phy->band_idx);
+       if ((info->flags & IEEE80211_TX_CTL_TX_OFFCHAN) ||
+-          (info->control.flags & IEEE80211_TX_CTRL_SCAN_TX))
++          (info->control.flags & IEEE80211_TX_CTRL_DONT_USE_RATE_MASK))
+               head = &wcid->tx_offchannel;
+       else
+               head = &wcid->tx_pending;