kernel: bump 4.9 to 4.9.148
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 7 Jan 2019 10:09:26 +0000 (11:09 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 8 Jan 2019 12:13:16 +0000 (13:13 +0100)
Refreshed all patches.

Altered patches:
- 902-debloat_proc.patch

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/100-arm-cns3xxx-fix-writing-to-wrong-PCI-registers-after.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch
target/linux/generic/pending-4.9/834-ledtrig-libata.patch

index 826e27c3fd07420282a93e1d23fbafdf9d311ee7..af36f408e3574ffccae9fcf12ed8ed987393d397 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .146
+LINUX_VERSION-4.9 = .148
 LINUX_VERSION-4.14 = .89
 
-LINUX_KERNEL_HASH-4.9.146 = 58195a8be3085d117c83a2ed1caa3b46ea7c1614c75f951b9f13f7adb03f8e59
+LINUX_KERNEL_HASH-4.9.148 = 6067151b0225a8de1ab79abc9be7bae237eaca0cd838eb26684169560d88a994
 LINUX_KERNEL_HASH-4.14.89 = ce6e16ac44dddd0d6a232bf2ce03e8bf8beca19f9b84503684466d140a1a0b25
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 458515a0b59f4e6c37e161bf19bd60dca4a5d738..faeb3e417006bce6e166bc5a8426d40e81160bdd 100644 (file)
@@ -61,11 +61,9 @@ CC: stable@vger.kernel.org # v4.0+
  arch/arm/mach-cns3xxx/pcie.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/arch/arm/mach-cns3xxx/pcie.c b/arch/arm/mach-cns3xxx/pcie.c
-index 318394ed5c7a..5e11ad3164e0 100644
 --- a/arch/arm/mach-cns3xxx/pcie.c
 +++ b/arch/arm/mach-cns3xxx/pcie.c
-@@ -83,7 +83,7 @@ static void __iomem *cns3xxx_pci_map_bus(struct pci_bus *bus,
+@@ -83,7 +83,7 @@ static void __iomem *cns3xxx_pci_map_bus
        } else /* remote PCI bus */
                base = cnspci->cfg1_regs + ((busno & 0xf) << 20);
  
@@ -74,6 +72,3 @@ index 318394ed5c7a..5e11ad3164e0 100644
  }
  
  static int cns3xxx_pci_read_config(struct pci_bus *bus, unsigned int devfn,
--- 
-2.17.1
-
index 3095f832a27684714e4dc0e6f60620337c575456..f9a1e320986e55b755bd2eb7056c8a94c94a0814 100644 (file)
@@ -221,13 +221,14 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!root_irq_dir)
 --- a/kernel/time/timer_list.c
 +++ b/kernel/time/timer_list.c
-@@ -399,6 +399,8 @@ static int __init init_timer_list_procfs
+@@ -399,6 +399,9 @@ static int __init init_timer_list_procfs
  {
        struct proc_dir_entry *pe;
  
 +      if (IS_ENABLED(CONFIG_PROC_STRIPPED))
 +              return 0;
-       pe = proc_create("timer_list", 0444, NULL, &timer_list_fops);
++
+       pe = proc_create("timer_list", 0400, NULL, &timer_list_fops);
        if (!pe)
                return -ENOMEM;
 --- a/mm/vmalloc.c
index b2c0b4898076470aafc839e10f471bba56faefc4..4715182c6b3a4608d161678787a71d70e61fc88c 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4994,6 +5007,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4995,6 +5008,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -5895,6 +5911,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5896,6 +5912,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5916,6 +5935,12 @@ static void ata_host_release(struct devi
+@@ -5917,6 +5936,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6362,7 +6387,23 @@ int ata_host_register(struct ata_host *h
+@@ -6363,7 +6388,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }