projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
52d6719
)
[PATCH] #9863: don't export target $PROFILE into postgresql
author
Jo-Philipp Wich
<jow@openwrt.org>
Mon, 1 Aug 2011 00:34:09 +0000
(
00:34
+0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Mon, 1 Aug 2011 00:34:09 +0000
(
00:34
+0000)
PROFILE is overloaded by postgresql versus how target's define it.
Fixes: https://dev.openwrt.org/ticket/9863
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 27856
libs/postgresql/Makefile
patch
|
blob
|
history
diff --git
a/libs/postgresql/Makefile
b/libs/postgresql/Makefile
index 2120155ad0264e59f774a293b15a6ad1b3b34d31..bd774873fb92779c4b62257ec3baf0dd3d86732c 100644
(file)
--- a/
libs/postgresql/Makefile
+++ b/
libs/postgresql/Makefile
@@
-156,6
+156,9
@@
endef
TARGET_CFLAGS += $(FPIC)
+# because PROFILE means something else in the project Makefile
+unexport PROFILE
+
define Build/Compile
$(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" \
DESTDIR="$(PKG_INSTALL_DIR)" \