Finally fix HOSTCC CFLAGS, should close #707
authorFlorian Fainelli <florian@openwrt.org>
Wed, 23 Aug 2006 14:23:04 +0000 (14:23 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 23 Aug 2006 14:23:04 +0000 (14:23 +0000)
SVN-Revision: 4636

openwrt/package/iproute2/Makefile
openwrt/package/iproute2/patches/004-hostcc_cflags.patch [deleted file]

index f7b63f30c6393566cba3d550fd4f6631df1407fd..2191dbaef5552e76b214994dbd4a79974117fa31 100644 (file)
@@ -30,7 +30,7 @@ $(PKG_BUILD_DIR)/.configured:
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR)/netem HOSTCC=$(HOSTCC) CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
+       $(MAKE) -j1 -C $(PKG_BUILD_DIR)/netem HOSTCC=$(HOSTCC) CFLAGS="-D_GNU_SOURCE -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
        $(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
        touch $@
 
diff --git a/openwrt/package/iproute2/patches/004-hostcc_cflags.patch b/openwrt/package/iproute2/patches/004-hostcc_cflags.patch
deleted file mode 100644 (file)
index 6584f57..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -urN iproute2-2.6.11-050330/netem/Makefile iproute2-2.6.11-050330.new/netem/Makefile
---- iproute2-2.6.11-050330/netem/Makefile      2005-04-01 21:58:11.000000000 +0200
-+++ iproute2-2.6.11-050330.new/netem/Makefile  2006-08-23 10:23:05.000000000 +0200
-@@ -1,5 +1,6 @@
- DISTGEN = maketable normal pareto paretonormal
- DISTDATA = normal.dist pareto.dist paretonormal.dist experimental.dist
-+CFLAGS = -D_GNU_SOURCE -Os -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES
- LDLIBS += -lm