apf: do not override CFLAGS in configure script
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:58:02 +0000 (00:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:58:02 +0000 (00:58 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39834

net/apf/Makefile
net/apf/patches/001-cflags_override.patch [new file with mode: 0644]

index 89e46aa513d5774428fd94315a531ee1e94a3b29..9e786774323c55937041c09ac8551928f504c114 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apf
 PKG_VERSION:=0.8.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://gray-world.net/projects/af/
 PKG_MD5SUM:=4411785b05ec59e955152fe4e61705b1
+PKG_FIXUP:=autoreconf
 
 PKG_INSTALL:=1
 
diff --git a/net/apf/patches/001-cflags_override.patch b/net/apf/patches/001-cflags_override.patch
new file mode 100644 (file)
index 0000000..80d85e9
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -28,8 +28,6 @@ AC_CONFIG_FILES([Makefile
+                  modules/Makefile
+                  src/Makefile])
+-CFLAGS="-pedantic -Wall -O2"
+-
+ # Enabling/disabling asserts and debugging
+ AC_MSG_CHECKING(whether to enable debugging)
+ AC_ARG_ENABLE(debug, [  --enable-debug=[no/yes] turn on debugging