Added missing net/freeswitch/files/etc.minimal/autoload_configs/dingaling.conf.xml...
authorMazi Lo <OpenWRT@slickdeals.endjunk.com>
Fri, 16 Sep 2011 01:24:33 +0000 (01:24 +0000)
committerMazi Lo <OpenWRT@slickdeals.endjunk.com>
Fri, 16 Sep 2011 01:24:33 +0000 (01:24 +0000)
SVN-Revision: 28246

net/freeswitch/Makefile
net/freeswitch/files/etc.minimal/autoload_configs/dingaling.conf.xml [new file with mode: 0644]

index b1f8f3af65bb135c4f64a374760eb8f237c70e51..fc7acc8262a7c120a027119674383d356dc37e40 100644 (file)
@@ -16,7 +16,7 @@ PKG_RELEASE:=1
 #
 # The latest FS git hash in PKG_REV can be obtained from http://fisheye.freeswitch.org
 #
-PKG_REV:=7d399cce96bd01a35e351b81b20f9792d5ee9ff0
+PKG_REV:=25417d3ea8d4f1b8e192d79ebad8e9d45dc85790
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
@@ -217,25 +217,28 @@ endef
 define Package/$(PKG_NAME)-mod-sofia/config
     config FS_SOFIA_WITH_ODBC
     depends on PACKAGE_$(PKG_NAME)-mod-sofia
+    depends on PACKAGE_unixodbc_svn
     bool "Compile with ODBC support (Requires unixodbc_svn NOT YET AVAILABLE)"
     default n
-    select PACKAGE_unixodbc_svn
+    #select PACKAGE_unixodbc_svn
     help
             Compile $(PKG_NAME)-mod-sofia with ODBC Support. Since unixodbc_svn package is not yet available on OpenWRT, $(PKG_NAME)-mod-sofia CAN NOT be compiled with ODBC support.
 
     config FS_SOFIA_WITH_SCTP
     depends on PACKAGE_$(PKG_NAME)-mod-sofia
+    depends on PACKAGE_sctp
     bool "Compile with SCTP (Stream Control Transfer Protocol) support"
     default n
-    select PACKAGE_sctp
+    #select PACKAGE_sctp
     help
             Compile $(PKG_NAME)-mod-sofia with SCTP support.
 
     config FS_SOFIA_WITH_ZRTP_GIT
     depends on PACKAGE_$(PKG_NAME)-mod-sofia
+    depends on PACKAGE_libzrtpcpp
     bool "Compile with ZRTP support (Requires libzrtpcpp NOT YET AVAILABLE)"
     default n
-    select PACKAGE_libzrtpcpp
+    #select PACKAGE_libzrtpcpp
     help
             Compile $(PKG_NAME)-mod-sofia with ZRTP Support. Since libzrtpcpp package is not yet available on OpenWRT, $(PKG_NAME)-mod-sofia CAN NOT be compiled with ZRTP support.
 endef
@@ -756,7 +759,7 @@ $(eval $(call BuildPlugin,shell-stream,Shell stream,mod_shell_stream,,))
 $(eval $(call BuildPlugin,silk,codec mod_silk,mod_silk,,))
 $(eval $(call BuildPlugin,siren,G.722.1 codec,mod_siren,,))
 $(eval $(call BuildPlugin,skinny,endpoint mod_skinny,mod_skinny,,))
-$(eval $(call BuildPlugin,skypopen,Skype compatible endpoint,mod_skypopen,,@FEATURE_drawing-backend_libX11 +libX11))
+$(eval $(call BuildPlugin,skypopen,Skype compatible endpoint,mod_skypopen,,+FEATURE_drawing-backend_libX11:libX11))
 $(eval $(call BuildPlugin,snapshot,application mod_snapshot,mod_snapshot,,))
 $(eval $(call BuildPlugin,sndfile,Multi-Format file transcoder,mod_sndfile,,))
 $(eval $(call BuildPlugin,snipe-hunt,application mod_snipe_hunt,mod_snipe_hunt,,))
diff --git a/net/freeswitch/files/etc.minimal/autoload_configs/dingaling.conf.xml b/net/freeswitch/files/etc.minimal/autoload_configs/dingaling.conf.xml
new file mode 100644 (file)
index 0000000..e68c8b4
--- /dev/null
@@ -0,0 +1,9 @@
+<configuration name="dingaling.conf" description="XMPP Jingle Endpoint">
+  <settings>
+    <param name="debug" value="0"/>
+    <param name="codec-prefs" value="PCMU"/>
+  </settings>
+
+  <X-PRE-PROCESS cmd="include" data="../jingle_profiles/*.xml"/>
+
+</configuration>