ucode: update to Git HEAD (2024-07-11) main
authorJo-Philipp Wich <jo@mein.io>
Thu, 11 Jul 2024 22:09:47 +0000 (00:09 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 11 Jul 2024 22:26:45 +0000 (00:26 +0200)
8cf816d615fd socket: fix potential memory leak in connect()
8f5f231d66cd socket: optimize poll() argument handling
36f106056069 socket: remove wrong documentation fragment
525fca224012 socket: uv_to_sockaddr(): fix length calculation for AF_UNIX addresses
3938645ad9e3 socket: support IPv6 addresses in struct conversion routines
3a586dc7ddbe socket: improve uc_socket_connect() behavior
7b269f1cd3d2 socket: improve uc_socket_listen() behavior
fc6f2b89febf socket: handle further socket option value types
d6f25797dad1 socket: add IPv6 socket options
7611487b9a05 socket: implement recvmsg(), sendmsg() and cmsg support
d2e44bfa8b54 core-lib: improved documentation
e0bab40c8578 fs: add truncate() file method
5d305cfb2ab7 fs: add lock() file method
8b0318f7fabe lib: introduce zlib library
73644a036f5a nl80211: move access to tb array out of uc_nl_convert_attr and below
6e3cf83a77a7 nl80211: add support for multi-attribute arrays
6ff24d5488a9 nl80211: update nl80211.h to latest wireless-next
abc2aef28641 nl80211: add wiphy multi-radio support
115a84fa3c13 nl80211: gracefully handle illegal netlink error code
f6ea6fc8f026 nl80211: support conversion from/to struct array attributes
f5b5a5835965 nl80211: drop unused structure members from connection context
bc13278eae5e nl80211: support the MAC80211_HWSIM netlink protocol family

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/ucode/Makefile

index ac23161c5e949625108fe443bd67aee95f83d29e..27c8c8a32e1aedc9efd9038c97180a445f403c68 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2024-05-09
-PKG_SOURCE_VERSION:=0d823e702bfe5f2bb5be694030a98afedf34aa6b
-PKG_MIRROR_HASH:=c52d499d2490e958e36ed80c32e8fd6d94cacf3b43b9d14c45c68a25bc44d536
+PKG_SOURCE_DATE:=2024-07-11
+PKG_SOURCE_VERSION:=b391fd7a77f5cb6fd34650dc7a90bb4f8c120131
+PKG_MIRROR_HASH:=c6741e849ba7235d0a732df6db43cb0b2423f1120af6c176884864b597eb4e56
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC
 
@@ -43,12 +43,14 @@ CMAKE_HOST_OPTIONS += \
        -DNL80211_SUPPORT=OFF \
        -DRESOLV_SUPPORT=OFF \
        -DRTNL_SUPPORT=OFF \
+       -DSOCKET_SUPPORT=OFF \
        -DSTRUCT_SUPPORT=ON \
        -DUBUS_SUPPORT=OFF \
        -DUCI_SUPPORT=OFF \
        -DULOOP_SUPPORT=OFF \
        -DDEBUG_SUPPORT=ON \
-       -DLOG_SUPPORT=OFF
+       -DLOG_SUPPORT=OFF \
+       -DZLIB_SUPPORT=OFF
 
 
 define Package/ucode/default
@@ -175,6 +177,10 @@ $(eval $(call UcodeModule, \
        uloop, ULOOP_SUPPORT, +libubox, \
        The uloop module allows ucode scripts to interact with OpenWrt uloop event loop implementation.))
 
+$(eval $(call UcodeModule, \
+       zlib, ZLIB_SUPPORT, +zlib, \
+       The zlib module exposes the Zlib deflate and inflate APIs.))
+
 $(eval $(call BuildPackage,libucode))
 $(eval $(call BuildPackage,ucode))