Move 09-rename-iwl4965-config.patch to 08
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 12 Aug 2009 21:24:28 +0000 (14:24 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 12 Aug 2009 21:24:28 +0000 (14:24 -0700)
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
compat/patches/08-rename-iwl4965-config.patch [new file with mode: 0644]
compat/patches/09-rename-iwl4965-config.patch [deleted file]

diff --git a/compat/patches/08-rename-iwl4965-config.patch b/compat/patches/08-rename-iwl4965-config.patch
new file mode 100644 (file)
index 0000000..2a89bbe
--- /dev/null
@@ -0,0 +1,31 @@
+In kernel 2.6.26 and older CONFIG_IWL4965 was build as an extra
+module, but now it is directly included in the iwlagn.
+
+CONFIG_IWL4965 has to be set to y, to build correctly.
+
+--- a/drivers/net/wireless/iwlwifi/Makefile
++++ b/drivers/net/wireless/iwlwifi/Makefile
+@@ -9,7 +9,7 @@ iwlcore-$(CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT) += iwl-spectrum.o
+ obj-$(CONFIG_IWLAGN)  += iwlagn.o
+ iwlagn-objs           := iwl-agn.o iwl-agn-rs.o
+-iwlagn-$(CONFIG_IWL4965) += iwl-4965.o
++iwlagn-$(CONFIG_COMPAT_IWL4965) += iwl-4965.o
+ iwlagn-$(CONFIG_IWL5000) += iwl-5000.o
+ iwlagn-$(CONFIG_IWL5000) += iwl-6000.o
+ iwlagn-$(CONFIG_IWL5000) += iwl-1000.o
+--- a/drivers/net/wireless/iwlwifi/iwl-agn.c   2009-08-10 17:02:12.903465688 -0700
++++ b/drivers/net/wireless/iwlwifi/iwl-agn.c   2009-08-10 17:02:13.879468854 -0700
+@@ -3003,10 +3003,10 @@
+ /* Hardware specific file defines the PCI IDs table for that hardware module */
+ static struct pci_device_id iwl_hw_card_ids[] = {
+-#ifdef CONFIG_IWL4965
++#ifdef CONFIG_COMPAT_IWL4965
+       {IWL_PCI_DEVICE(0x4229, PCI_ANY_ID, iwl4965_agn_cfg)},
+       {IWL_PCI_DEVICE(0x4230, PCI_ANY_ID, iwl4965_agn_cfg)},
+-#endif /* CONFIG_IWL4965 */
++#endif /* CONFIG_COMPAT_IWL4965 */
+ #ifdef CONFIG_IWL5000
+       {IWL_PCI_DEVICE(0x4232, 0x1205, iwl5100_bg_cfg)},
+       {IWL_PCI_DEVICE(0x4232, 0x1305, iwl5100_bg_cfg)},
diff --git a/compat/patches/09-rename-iwl4965-config.patch b/compat/patches/09-rename-iwl4965-config.patch
deleted file mode 100644 (file)
index 2a89bbe..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-In kernel 2.6.26 and older CONFIG_IWL4965 was build as an extra
-module, but now it is directly included in the iwlagn.
-
-CONFIG_IWL4965 has to be set to y, to build correctly.
-
---- a/drivers/net/wireless/iwlwifi/Makefile
-+++ b/drivers/net/wireless/iwlwifi/Makefile
-@@ -9,7 +9,7 @@ iwlcore-$(CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT) += iwl-spectrum.o
- obj-$(CONFIG_IWLAGN)  += iwlagn.o
- iwlagn-objs           := iwl-agn.o iwl-agn-rs.o
--iwlagn-$(CONFIG_IWL4965) += iwl-4965.o
-+iwlagn-$(CONFIG_COMPAT_IWL4965) += iwl-4965.o
- iwlagn-$(CONFIG_IWL5000) += iwl-5000.o
- iwlagn-$(CONFIG_IWL5000) += iwl-6000.o
- iwlagn-$(CONFIG_IWL5000) += iwl-1000.o
---- a/drivers/net/wireless/iwlwifi/iwl-agn.c   2009-08-10 17:02:12.903465688 -0700
-+++ b/drivers/net/wireless/iwlwifi/iwl-agn.c   2009-08-10 17:02:13.879468854 -0700
-@@ -3003,10 +3003,10 @@
- /* Hardware specific file defines the PCI IDs table for that hardware module */
- static struct pci_device_id iwl_hw_card_ids[] = {
--#ifdef CONFIG_IWL4965
-+#ifdef CONFIG_COMPAT_IWL4965
-       {IWL_PCI_DEVICE(0x4229, PCI_ANY_ID, iwl4965_agn_cfg)},
-       {IWL_PCI_DEVICE(0x4230, PCI_ANY_ID, iwl4965_agn_cfg)},
--#endif /* CONFIG_IWL4965 */
-+#endif /* CONFIG_COMPAT_IWL4965 */
- #ifdef CONFIG_IWL5000
-       {IWL_PCI_DEVICE(0x4232, 0x1205, iwl5100_bg_cfg)},
-       {IWL_PCI_DEVICE(0x4232, 0x1305, iwl5100_bg_cfg)},