projects
/
openwrt
/
staging
/
neocturne.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a21fbec
)
imagebuilder: merge r25078 to align files/ handling with current buildroot
author
Jo-Philipp Wich
<jow@openwrt.org>
Thu, 22 Nov 2012 19:46:54 +0000
(19:46 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Thu, 22 Nov 2012 19:46:54 +0000
(19:46 +0000)
SVN-Revision: 34301
target/imagebuilder/files/Makefile
patch
|
blob
|
history
diff --git
a/target/imagebuilder/files/Makefile
b/target/imagebuilder/files/Makefile
index b0d0698acdc5370ab48e9e25dc858643d060bd4f..4d0f1fe1159124c44266579ba5dc590a846e9216 100644
(file)
--- a/
target/imagebuilder/files/Makefile
+++ b/
target/imagebuilder/files/Makefile
@@
-134,6
+134,14
@@
package_install: FORCE
copy_files: FORCE
@echo
@echo Copying extra files
+ @( cd $(USER_FILES); find -type f ) | \
+ ( cd $(TARGET_DIR); while :; do \
+ read FILE; \
+ [ -z "$$FILE" ] && break; \
+ [ -L "$$FILE" ] || continue; \
+ echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
+ rm -f "$$FILE"; \
+ done; )
$(CP) $(USER_FILES)/* $(TARGET_DIR)/
package_postinst: FORCE