https://sourceware.org/bugzilla/show_bug.cgi?id=21002
-Index: elfutils-0.169/lib/system.h
-===================================================================
---- elfutils-0.169.orig/lib/system.h
-+++ elfutils-0.169/lib/system.h
+--- a/lib/system.h
++++ b/lib/system.h
@@ -29,7 +29,18 @@
#ifndef LIB_SYSTEM_H
#define LIB_SYSTEM_H 1
#if __BYTE_ORDER == __LITTLE_ENDIAN
# define LE32(n) (n)
# define LE64(n) (n)
-Index: elfutils-0.169/lib/color.c
-===================================================================
---- elfutils-0.169.orig/lib/color.c
-+++ elfutils-0.169/lib/color.c
+--- a/lib/color.c
++++ b/lib/color.c
@@ -32,13 +32,13 @@
#endif
/* Prototype for option handler. */
static error_t parse_opt (int key, char *arg, struct argp_state *state);
-Index: elfutils-0.169/lib/xmalloc.c
-===================================================================
---- elfutils-0.169.orig/lib/xmalloc.c
-+++ elfutils-0.169/lib/xmalloc.c
+--- a/lib/xmalloc.c
++++ b/lib/xmalloc.c
@@ -30,7 +30,6 @@
# include <config.h>
#endif
#include <libintl.h>
#include <stddef.h>
#include <stdlib.h>
-Index: elfutils-0.169/src/addr2line.c
-===================================================================
---- elfutils-0.169.orig/src/addr2line.c
-+++ elfutils-0.169/src/addr2line.c
+--- a/src/addr2line.c
++++ b/src/addr2line.c
@@ -23,7 +23,6 @@
#include <argp.h>
#include <assert.h>
#include <fcntl.h>
#include <inttypes.h>
#include <libdwfl.h>
-Index: elfutils-0.169/src/ar.c
-===================================================================
---- elfutils-0.169.orig/src/ar.c
-+++ elfutils-0.169/src/ar.c
+--- a/src/ar.c
++++ b/src/ar.c
@@ -22,7 +22,6 @@
#include <argp.h>
#include <fcntl.h>
#include <gelf.h>
#include <libintl.h>
-Index: elfutils-0.169/src/arlib2.c
-===================================================================
---- elfutils-0.169.orig/src/arlib2.c
-+++ elfutils-0.169/src/arlib2.c
+--- a/src/arlib2.c
++++ b/src/arlib2.c
@@ -20,7 +20,6 @@
# include <config.h>
#endif
#include <libintl.h>
#include <limits.h>
#include <string.h>
-Index: elfutils-0.169/src/arlib.c
-===================================================================
---- elfutils-0.169.orig/src/arlib.c
-+++ elfutils-0.169/src/arlib.c
+--- a/src/arlib.c
++++ b/src/arlib.c
@@ -21,7 +21,6 @@
#endif
#include <gelf.h>
#include <inttypes.h>
#include <libintl.h>
-Index: elfutils-0.169/src/elfcmp.c
-===================================================================
---- elfutils-0.169.orig/src/elfcmp.c
-+++ elfutils-0.169/src/elfcmp.c
+--- a/src/elfcmp.c
++++ b/src/elfcmp.c
@@ -23,7 +23,6 @@
#include <argp.h>
#include <assert.h>
#include <fcntl.h>
#include <locale.h>
#include <libintl.h>
-Index: elfutils-0.169/src/elflint.c
-===================================================================
---- elfutils-0.169.orig/src/elflint.c
-+++ elfutils-0.169/src/elflint.c
+--- a/src/elflint.c
++++ b/src/elflint.c
@@ -24,7 +24,6 @@
#include <assert.h>
#include <byteswap.h>
#include <fcntl.h>
#include <gelf.h>
#include <inttypes.h>
-Index: elfutils-0.169/src/findtextrel.c
-===================================================================
---- elfutils-0.169.orig/src/findtextrel.c
-+++ elfutils-0.169/src/findtextrel.c
+--- a/src/findtextrel.c
++++ b/src/findtextrel.c
@@ -23,7 +23,6 @@
#include <argp.h>
#include <assert.h>
#include <fcntl.h>
#include <gelf.h>
#include <libdw.h>
-Index: elfutils-0.169/src/nm.c
-===================================================================
---- elfutils-0.169.orig/src/nm.c
-+++ elfutils-0.169/src/nm.c
+--- a/src/nm.c
++++ b/src/nm.c
@@ -26,7 +26,6 @@
#include <ctype.h>
#include <dwarf.h>
#include <fcntl.h>
#include <gelf.h>
#include <inttypes.h>
-Index: elfutils-0.169/src/objdump.c
-===================================================================
---- elfutils-0.169.orig/src/objdump.c
-+++ elfutils-0.169/src/objdump.c
+--- a/src/objdump.c
++++ b/src/objdump.c
@@ -21,7 +21,6 @@
#endif
#include <fcntl.h>
#include <inttypes.h>
#include <libintl.h>
-Index: elfutils-0.169/src/ranlib.c
-===================================================================
---- elfutils-0.169.orig/src/ranlib.c
-+++ elfutils-0.169/src/ranlib.c
+--- a/src/ranlib.c
++++ b/src/ranlib.c
@@ -24,7 +24,6 @@
#include <argp.h>
#include <assert.h>
#include <fcntl.h>
#include <gelf.h>
#include <libintl.h>
-Index: elfutils-0.169/src/readelf.c
-===================================================================
---- elfutils-0.169.orig/src/readelf.c
-+++ elfutils-0.169/src/readelf.c
-@@ -25,7 +25,6 @@
+--- a/src/readelf.c
++++ b/src/readelf.c
+@@ -24,7 +24,6 @@
#include <ctype.h>
#include <dwarf.h>
#include <errno.h>
#include <fcntl.h>
#include <gelf.h>
#include <inttypes.h>
-Index: elfutils-0.169/src/size.c
-===================================================================
---- elfutils-0.169.orig/src/size.c
-+++ elfutils-0.169/src/size.c
+--- a/src/size.c
++++ b/src/size.c
@@ -21,7 +21,6 @@
#endif
#include <fcntl.h>
#include <gelf.h>
#include <inttypes.h>
-Index: elfutils-0.169/src/stack.c
-===================================================================
---- elfutils-0.169.orig/src/stack.c
-+++ elfutils-0.169/src/stack.c
+--- a/src/stack.c
++++ b/src/stack.c
@@ -18,7 +18,6 @@
#include <config.h>
#include <assert.h>
#include <stdlib.h>
#include <inttypes.h>
#include <stdio.h>
-Index: elfutils-0.169/src/strings.c
-===================================================================
---- elfutils-0.169.orig/src/strings.c
-+++ elfutils-0.169/src/strings.c
+--- a/src/strings.c
++++ b/src/strings.c
@@ -25,7 +25,6 @@
#include <ctype.h>
#include <endian.h>
#include <fcntl.h>
#include <gelf.h>
#include <inttypes.h>
-Index: elfutils-0.169/src/strip.c
-===================================================================
---- elfutils-0.169.orig/src/strip.c
-+++ elfutils-0.169/src/strip.c
+--- a/src/strip.c
++++ b/src/strip.c
@@ -24,7 +24,6 @@
#include <assert.h>
#include <byteswap.h>
#include <endian.h>
-#include <error.h>
#include <fcntl.h>
+ #include <fnmatch.h>
#include <gelf.h>
- #include <libelf.h>
-Index: elfutils-0.169/src/unstrip.c
-===================================================================
---- elfutils-0.169.orig/src/unstrip.c
-+++ elfutils-0.169/src/unstrip.c
+--- a/src/unstrip.c
++++ b/src/unstrip.c
@@ -31,7 +31,6 @@
#include <argp.h>
#include <assert.h>
#include <fcntl.h>
#include <fnmatch.h>
#include <libintl.h>
-Index: elfutils-0.169/tests/addrscopes.c
-===================================================================
---- elfutils-0.169.orig/tests/addrscopes.c
-+++ elfutils-0.169/tests/addrscopes.c
+--- a/tests/addrscopes.c
++++ b/tests/addrscopes.c
@@ -25,7 +25,6 @@
#include <stdio_ext.h>
#include <locale.h>
#include <string.h>
-Index: elfutils-0.169/tests/allregs.c
-===================================================================
---- elfutils-0.169.orig/tests/allregs.c
-+++ elfutils-0.169/tests/allregs.c
+--- a/tests/allregs.c
++++ b/tests/allregs.c
@@ -21,7 +21,6 @@
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
#include <argp.h>
#include <assert.h>
-Index: elfutils-0.169/tests/backtrace.c
-===================================================================
---- elfutils-0.169.orig/tests/backtrace.c
-+++ elfutils-0.169/tests/backtrace.c
+--- a/tests/backtrace.c
++++ b/tests/backtrace.c
@@ -24,7 +24,6 @@
#include <dirent.h>
#include <stdlib.h>
#include <unistd.h>
#include <dwarf.h>
#ifdef __linux__
-Index: elfutils-0.169/tests/backtrace-data.c
-===================================================================
---- elfutils-0.169.orig/tests/backtrace-data.c
-+++ elfutils-0.169/tests/backtrace-data.c
+--- a/tests/backtrace-data.c
++++ b/tests/backtrace-data.c
@@ -27,7 +27,6 @@
#include <dirent.h>
#include <stdlib.h>
#include <unistd.h>
#include <dwarf.h>
#if defined(__x86_64__) && defined(__linux__)
-Index: elfutils-0.169/tests/buildid.c
-===================================================================
---- elfutils-0.169.orig/tests/buildid.c
-+++ elfutils-0.169/tests/buildid.c
+--- a/tests/buildid.c
++++ b/tests/buildid.c
@@ -23,7 +23,6 @@
#include ELFUTILS_HEADER(elf)
#include ELFUTILS_HEADER(dwelf)
#include <string.h>
#include <stdlib.h>
#include <sys/types.h>
-Index: elfutils-0.169/tests/debugaltlink.c
-===================================================================
---- elfutils-0.169.orig/tests/debugaltlink.c
-+++ elfutils-0.169/tests/debugaltlink.c
+--- a/tests/debugaltlink.c
++++ b/tests/debugaltlink.c
@@ -23,7 +23,6 @@
#include ELFUTILS_HEADER(dw)
#include ELFUTILS_HEADER(dwelf)
#include <string.h>
#include <stdlib.h>
#include <sys/types.h>
-Index: elfutils-0.169/tests/debuglink.c
-===================================================================
---- elfutils-0.169.orig/tests/debuglink.c
-+++ elfutils-0.169/tests/debuglink.c
+--- a/tests/debuglink.c
++++ b/tests/debuglink.c
@@ -21,7 +21,6 @@
#include <errno.h>
#include ELFUTILS_HEADER(dwelf)
#include <string.h>
#include <stdlib.h>
#include <sys/types.h>
-Index: elfutils-0.169/tests/dwfl-addr-sect.c
-===================================================================
---- elfutils-0.169.orig/tests/dwfl-addr-sect.c
-+++ elfutils-0.169/tests/dwfl-addr-sect.c
+--- a/tests/dwfl-addr-sect.c
++++ b/tests/dwfl-addr-sect.c
@@ -23,7 +23,6 @@
#include <stdio_ext.h>
#include <stdlib.h>
#include <locale.h>
#include <argp.h>
#include ELFUTILS_HEADER(dwfl)
-Index: elfutils-0.169/tests/dwfl-bug-addr-overflow.c
-===================================================================
---- elfutils-0.169.orig/tests/dwfl-bug-addr-overflow.c
-+++ elfutils-0.169/tests/dwfl-bug-addr-overflow.c
+--- a/tests/dwfl-bug-addr-overflow.c
++++ b/tests/dwfl-bug-addr-overflow.c
@@ -20,7 +20,6 @@
#include <inttypes.h>
#include <stdio.h>
#include <locale.h>
#include ELFUTILS_HEADER(dwfl)
-Index: elfutils-0.169/tests/dwfl-bug-fd-leak.c
-===================================================================
---- elfutils-0.169.orig/tests/dwfl-bug-fd-leak.c
-+++ elfutils-0.169/tests/dwfl-bug-fd-leak.c
+--- a/tests/dwfl-bug-fd-leak.c
++++ b/tests/dwfl-bug-fd-leak.c
@@ -24,7 +24,6 @@
#include <dirent.h>
#include <stdlib.h>
#include <unistd.h>
#include <dwarf.h>
-Index: elfutils-0.169/tests/dwfl-bug-getmodules.c
-===================================================================
---- elfutils-0.169.orig/tests/dwfl-bug-getmodules.c
-+++ elfutils-0.169/tests/dwfl-bug-getmodules.c
+--- a/tests/dwfl-bug-getmodules.c
++++ b/tests/dwfl-bug-getmodules.c
@@ -18,7 +18,6 @@
#include <config.h>
#include ELFUTILS_HEADER(dwfl)
static const Dwfl_Callbacks callbacks =
{
-Index: elfutils-0.169/tests/dwfllines.c
-===================================================================
---- elfutils-0.169.orig/tests/dwfllines.c
-+++ elfutils-0.169/tests/dwfllines.c
+--- a/tests/dwfllines.c
++++ b/tests/dwfllines.c
@@ -27,7 +27,6 @@
#include <stdio.h>
#include <stdlib.h>
int
main (int argc, char *argv[])
-Index: elfutils-0.169/tests/dwflmodtest.c
-===================================================================
---- elfutils-0.169.orig/tests/dwflmodtest.c
-+++ elfutils-0.169/tests/dwflmodtest.c
+--- a/tests/dwflmodtest.c
++++ b/tests/dwflmodtest.c
@@ -23,7 +23,6 @@
#include <stdio_ext.h>
#include <stdlib.h>
#include <locale.h>
#include <argp.h>
#include ELFUTILS_HEADER(dwfl)
-Index: elfutils-0.169/tests/dwfl-report-elf-align.c
-===================================================================
---- elfutils-0.169.orig/tests/dwfl-report-elf-align.c
-+++ elfutils-0.169/tests/dwfl-report-elf-align.c
+--- a/tests/dwfl-report-elf-align.c
++++ b/tests/dwfl-report-elf-align.c
@@ -20,7 +20,6 @@
#include <inttypes.h>
#include <stdio.h>
#include <locale.h>
#include <string.h>
#include <stdlib.h>
-Index: elfutils-0.169/tests/dwflsyms.c
-===================================================================
---- elfutils-0.169.orig/tests/dwflsyms.c
-+++ elfutils-0.169/tests/dwflsyms.c
+--- a/tests/dwflsyms.c
++++ b/tests/dwflsyms.c
@@ -25,7 +25,6 @@
#include <stdio.h>
#include <stdio_ext.h>
#include <string.h>
static const char *
-Index: elfutils-0.169/tests/early-offscn.c
-===================================================================
---- elfutils-0.169.orig/tests/early-offscn.c
-+++ elfutils-0.169/tests/early-offscn.c
+--- a/tests/early-offscn.c
++++ b/tests/early-offscn.c
@@ -19,7 +19,6 @@
#endif
#include <fcntl.h>
#include <gelf.h>
#include <stdio.h>
-Index: elfutils-0.169/tests/ecp.c
-===================================================================
---- elfutils-0.169.orig/tests/ecp.c
-+++ elfutils-0.169/tests/ecp.c
+--- a/tests/ecp.c
++++ b/tests/ecp.c
@@ -20,7 +20,6 @@
#endif
#include <fcntl.h>
#include <gelf.h>
#include <stdlib.h>
-Index: elfutils-0.169/tests/find-prologues.c
-===================================================================
---- elfutils-0.169.orig/tests/find-prologues.c
-+++ elfutils-0.169/tests/find-prologues.c
+--- a/tests/find-prologues.c
++++ b/tests/find-prologues.c
@@ -25,7 +25,6 @@
#include <stdio_ext.h>
#include <locale.h>
#include <string.h>
#include <fnmatch.h>
-Index: elfutils-0.169/tests/funcretval.c
-===================================================================
---- elfutils-0.169.orig/tests/funcretval.c
-+++ elfutils-0.169/tests/funcretval.c
+--- a/tests/funcretval.c
++++ b/tests/funcretval.c
@@ -25,7 +25,6 @@
#include <stdio_ext.h>
#include <locale.h>
#include <string.h>
#include <fnmatch.h>
-Index: elfutils-0.169/tests/funcscopes.c
-===================================================================
---- elfutils-0.169.orig/tests/funcscopes.c
-+++ elfutils-0.169/tests/funcscopes.c
+--- a/tests/funcscopes.c
++++ b/tests/funcscopes.c
@@ -25,7 +25,6 @@
#include <stdio_ext.h>
#include <locale.h>
#include <string.h>
#include <fnmatch.h>
-Index: elfutils-0.169/tests/line2addr.c
-===================================================================
---- elfutils-0.169.orig/tests/line2addr.c
-+++ elfutils-0.169/tests/line2addr.c
+--- a/tests/line2addr.c
++++ b/tests/line2addr.c
@@ -26,7 +26,6 @@
#include <locale.h>
#include <stdlib.h>
static void
-Index: elfutils-0.169/tests/low_high_pc.c
-===================================================================
---- elfutils-0.169.orig/tests/low_high_pc.c
-+++ elfutils-0.169/tests/low_high_pc.c
+--- a/tests/low_high_pc.c
++++ b/tests/low_high_pc.c
@@ -25,7 +25,6 @@
#include <stdio_ext.h>
#include <locale.h>
#include <string.h>
#include <fnmatch.h>
-Index: elfutils-0.169/tests/md5-sha1-test.c
-===================================================================
---- elfutils-0.169.orig/tests/md5-sha1-test.c
-+++ elfutils-0.169/tests/md5-sha1-test.c
-@@ -19,7 +19,6 @@
- #endif
-
- #include <string.h>
--#include <error.h>
-
- #include "md5.h"
- #include "sha1.h"
-Index: elfutils-0.169/tests/rdwrmmap.c
-===================================================================
---- elfutils-0.169.orig/tests/rdwrmmap.c
-+++ elfutils-0.169/tests/rdwrmmap.c
+--- a/tests/rdwrmmap.c
++++ b/tests/rdwrmmap.c
@@ -19,7 +19,6 @@
#endif
#include <stdio.h>
#include <fcntl.h>
#include <unistd.h>
-Index: elfutils-0.169/tests/saridx.c
-===================================================================
---- elfutils-0.169.orig/tests/saridx.c
-+++ elfutils-0.169/tests/saridx.c
+--- a/tests/saridx.c
++++ b/tests/saridx.c
@@ -17,7 +17,6 @@
#include <config.h>
#include <fcntl.h>
#include <gelf.h>
#include <stdio.h>
-Index: elfutils-0.169/tests/sectiondump.c
-===================================================================
---- elfutils-0.169.orig/tests/sectiondump.c
-+++ elfutils-0.169/tests/sectiondump.c
+--- a/tests/sectiondump.c
++++ b/tests/sectiondump.c
@@ -18,7 +18,6 @@
#include <config.h>
#include <fcntl.h>
#include <gelf.h>
#include <inttypes.h>
-Index: elfutils-0.169/tests/varlocs.c
-===================================================================
---- elfutils-0.169.orig/tests/varlocs.c
-+++ elfutils-0.169/tests/varlocs.c
+--- a/tests/varlocs.c
++++ b/tests/varlocs.c
@@ -25,7 +25,6 @@
#include <dwarf.h>
#include <stdio.h>
#include <string.h>
#include <sys/types.h>
#include <sys/stat.h>
-Index: elfutils-0.169/libasm/asm_end.c
-===================================================================
---- elfutils-0.169.orig/libasm/asm_end.c
-+++ elfutils-0.169/libasm/asm_end.c
+--- a/libasm/asm_end.c
++++ b/libasm/asm_end.c
@@ -32,7 +32,6 @@
#endif
#include <libintl.h>
#include <stdio.h>
#include <stdlib.h>
-Index: elfutils-0.169/libasm/asm_newscn.c
-===================================================================
---- elfutils-0.169.orig/libasm/asm_newscn.c
-+++ elfutils-0.169/libasm/asm_newscn.c
+--- a/libasm/asm_newscn.c
++++ b/libasm/asm_newscn.c
@@ -32,7 +32,6 @@
#endif
#include <libintl.h>
#include <stdlib.h>
#include <string.h>
-Index: elfutils-0.169/libcpu/i386_gendis.c
-===================================================================
---- elfutils-0.169.orig/libcpu/i386_gendis.c
-+++ elfutils-0.169/libcpu/i386_gendis.c
+--- a/libcpu/i386_gendis.c
++++ b/libcpu/i386_gendis.c
@@ -31,7 +31,6 @@
# include <config.h>
#endif
#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
-Index: elfutils-0.169/libcpu/i386_lex.c
-===================================================================
---- elfutils-0.169.orig/libcpu/i386_lex.c
-+++ elfutils-0.169/libcpu/i386_lex.c
-@@ -592,7 +592,6 @@ char *i386_text;
+--- a/libcpu/i386_lex.c
++++ b/libcpu/i386_lex.c
+@@ -808,7 +808,6 @@ char *yytext;
#endif
#include <ctype.h>
#include <libintl.h>
#include <libeu.h>
-Index: elfutils-0.169/libcpu/i386_lex.l
-===================================================================
---- elfutils-0.169.orig/libcpu/i386_lex.l
-+++ elfutils-0.169/libcpu/i386_lex.l
+--- a/libcpu/i386_lex.l
++++ b/libcpu/i386_lex.l
@@ -31,7 +31,6 @@
#endif
#include <libintl.h>
#include <libeu.h>
-Index: elfutils-0.169/libcpu/i386_parse.c
-===================================================================
---- elfutils-0.169.orig/libcpu/i386_parse.c
-+++ elfutils-0.169/libcpu/i386_parse.c
+--- a/libcpu/i386_parse.c
++++ b/libcpu/i386_parse.c
@@ -107,7 +107,6 @@
#include <assert.h>
#include <ctype.h>
#include <inttypes.h>
#include <libintl.h>
#include <math.h>
-Index: elfutils-0.169/libdw/libdw_alloc.c
-===================================================================
---- elfutils-0.169.orig/libdw/libdw_alloc.c
-+++ elfutils-0.169/libdw/libdw_alloc.c
+--- a/libdw/libdw_alloc.c
++++ b/libdw/libdw_alloc.c
@@ -31,7 +31,6 @@
# include <config.h>
#endif
#include <errno.h>
#include <stdlib.h>
#include "libdwP.h"
-@@ -74,5 +73,5 @@ __attribute ((noreturn, visibility ("hid
+@@ -74,5 +73,5 @@ __attribute ((noreturn)) attribute_hidde
__libdw_oom (void)
{
while (1)
- error (EXIT_FAILURE, ENOMEM, "libdw");
+ error (EXIT_FAILURE, errno, gettext ("cannot allocate memory"));
}
-Index: elfutils-0.169/libebl/eblopenbackend.c
-===================================================================
---- elfutils-0.169.orig/libebl/eblopenbackend.c
-+++ elfutils-0.169/libebl/eblopenbackend.c
+--- a/libebl/eblopenbackend.c
++++ b/libebl/eblopenbackend.c
@@ -32,7 +32,6 @@
#include <assert.h>
#include <libelfP.h>
#include <dwarf.h>
#include <stdlib.h>
-Index: elfutils-0.169/libdwfl/dwfl_error.c
-===================================================================
---- elfutils-0.169.orig/libdwfl/dwfl_error.c
-+++ elfutils-0.169/libdwfl/dwfl_error.c
+--- a/libdwfl/dwfl_error.c
++++ b/libdwfl/dwfl_error.c
@@ -140,6 +140,7 @@ __libdwfl_seterrno (Dwfl_Error error)
const char *
dwfl_errmsg (int error)
-Index: elfutils-0.169/libdwfl/argp-std.c
-===================================================================
---- elfutils-0.169.orig/libdwfl/argp-std.c
-+++ elfutils-0.169/libdwfl/argp-std.c
+--- a/libdwfl/argp-std.c
++++ b/libdwfl/argp-std.c
@@ -56,9 +56,6 @@ static const struct argp_option options[
{ "linux-process-map", 'M', "FILE", 0,
N_("Find addresses in files mapped as read from FILE"
/* Structure held at state->HOOK. */
struct parse_opt
{
-@@ -223,43 +211,6 @@ parse_opt (int key, char *arg, struct ar
+@@ -226,43 +214,6 @@ parse_opt (int key, char *arg, struct ar
}
break;
- Dwfl *dwfl = INTUSE(dwfl_begin) (&kernel_callbacks);
- int result = INTUSE(dwfl_linux_kernel_report_kernel) (dwfl);
- if (result != 0)
-- return fail (dwfl, result, _("cannot load kernel symbols"));
+- return fail (dwfl, result, _("cannot load kernel symbols"), state);
- result = INTUSE(dwfl_linux_kernel_report_modules) (dwfl);
- if (result != 0)
- /* Non-fatal to have no modules since we do have the kernel. */
-- failure (dwfl, result, _("cannot find kernel modules"));
+- argp_failure (state, 0, result, _("cannot find kernel modules"));
- opt->dwfl = dwfl;
- }
- else
- int result = INTUSE(dwfl_linux_kernel_report_offline) (dwfl, arg,
- NULL);
- if (result != 0)
-- return fail (dwfl, result, _("cannot find kernel or modules"));
+- return fail (dwfl, result, _("cannot find kernel or modules"), state);
- opt->dwfl = dwfl;
- }
- else
case ARGP_KEY_SUCCESS:
{
struct parse_opt *opt = state->hook;
-Index: elfutils-0.169/libdwfl/Makefile.in
-===================================================================
---- elfutils-0.169.orig/libdwfl/Makefile.in
-+++ elfutils-0.169/libdwfl/Makefile.in
-@@ -120,7 +120,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
- dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
- dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
- find-debuginfo.c dwfl_build_id_find_elf.c \
-- dwfl_build_id_find_debuginfo.c linux-kernel-modules.c \
-+ dwfl_build_id_find_debuginfo.c \
- linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
- dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
- dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
-@@ -148,7 +148,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
- dwfl_validate_address.$(OBJEXT) argp-std.$(OBJEXT) \
- find-debuginfo.$(OBJEXT) dwfl_build_id_find_elf.$(OBJEXT) \
- dwfl_build_id_find_debuginfo.$(OBJEXT) \
-- linux-kernel-modules.$(OBJEXT) linux-proc-maps.$(OBJEXT) \
-+ linux-proc-maps.$(OBJEXT) \
- dwfl_addrmodule.$(OBJEXT) dwfl_addrdwarf.$(OBJEXT) \
- cu.$(OBJEXT) dwfl_module_nextcu.$(OBJEXT) \
- dwfl_nextcu.$(OBJEXT) dwfl_cumodule.$(OBJEXT) \
-@@ -434,7 +434,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
- dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
- dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
- find-debuginfo.c dwfl_build_id_find_elf.c \
-- dwfl_build_id_find_debuginfo.c linux-kernel-modules.c \
-+ dwfl_build_id_find_debuginfo.c \
- linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
- dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
- dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
-@@ -571,7 +571,6 @@ distclean-compile:
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lines.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/link_map.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-core-attach.Po@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-kernel-modules.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-pid-attach.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-proc-maps.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lzma.Po@am__quote@
+--- a/libdwfl/Makefile.am
++++ b/libdwfl/Makefile.am
+@@ -49,7 +49,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
+ argp-std.c find-debuginfo.c \
+ dwfl_build_id_find_elf.c \
+ dwfl_build_id_find_debuginfo.c \
+- linux-kernel-modules.c linux-proc-maps.c \
++ linux-proc-maps.c \
+ dwfl_addrmodule.c dwfl_addrdwarf.c \
+ cu.c dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
+ dwfl_module_addrdie.c dwfl_addrdie.c \