projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
01ad421
)
FreeBSD fix to generate the menuconfig properly
author
Florian Fainelli
<florian@openwrt.org>
Wed, 2 Aug 2006 13:36:20 +0000
(13:36 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Wed, 2 Aug 2006 13:36:20 +0000
(13:36 +0000)
SVN-Revision: 4396
openwrt/scripts/config/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/scripts/config/Makefile
b/openwrt/scripts/config/Makefile
index a731a40e7cfa0c1568e3cdb36aa786bf5635d220..6cdab2e0e6df7aa00d548372136324b1c9875b71 100644
(file)
--- a/
openwrt/scripts/config/Makefile
+++ b/
openwrt/scripts/config/Makefile
@@
-9,6
+9,15
@@
# Utilizes the lxdialog package
# object files used by all kconfig flavours
+
+# Platform specific fixes
+#
+# FreeBSD
+ifeq ($(shell uname -s),FreeBSD)
+export CFLAGS+=-I/usr/local/include
+export LDFLAGS+=-L/usr/local/lib -lintl
+endif
+
conf-objs := conf.o zconf.tab.o
mconf-objs := mconf.o zconf.tab.o