projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
64170ab
)
toolchain: add musl libc.so to external toolchain
author
Hauke Mehrtens
<hauke.mehrtens@intel.com>
Tue, 14 Mar 2017 18:18:57 +0000
(19:18 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Wed, 15 Mar 2017 21:31:11 +0000
(22:31 +0100)
musl provides a /lib/libc.so file which should be integrated into the libc
package when the external toolchain with musl is used.
Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Reviewed-by: Florian Fainelli <f.fainelli@gmail.com>
Acked-by: Jo-Philipp Wich <jo@mein.io>
package/libs/toolchain/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/toolchain/Makefile
b/package/libs/toolchain/Makefile
index 8a90b5eda665803218bc0e1c1db9020bdf2855ce..0bf482402d0f908d2e07604eb99b6ddb0c6935f1 100644
(file)
--- a/
package/libs/toolchain/Makefile
+++ b/
package/libs/toolchain/Makefile
@@
-164,7
+164,7
@@
define Package/libc/config
string
prompt "libc shared library files (use wildcards)"
depends on EXTERNAL_TOOLCHAIN && PACKAGE_libc
- default "./lib/ld{*.so*,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*}"
+ default "./lib/ld{*.so*,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*
,.so
}"
endmenu
endef