[packages/backfire] twisted: merge [28426]
authorNicolas Thill <nico@openwrt.org>
Wed, 12 Oct 2011 06:51:18 +0000 (06:51 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 12 Oct 2011 06:51:18 +0000 (06:51 +0000)
SVN-Revision: 28427

lang/twisted/Makefile

index f0b75572716c501ea26a1e8ff7b34bfcd101e133..cabb8cb9569043be8c71efdd0b4bd9bf3dca155f 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -26,7 +26,7 @@ define Package/twisted/default
   SECTION:=lang
   CATEGORY:=Languages
   URL:=http://twistedmatrix.com/
-  DEPENDS:=+python-mini @BROKEN
+  DEPENDS:=+python-mini
 endef
 
 define Package/twisted/default/description
@@ -216,19 +216,13 @@ endef
 define Build/Compile
        $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
-               install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
+               install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" --no-compile, \
                TWISTED_SUBPROJECTS="$(TWISTED_SUBPROJECTS)" \
-               PYTHONPATH="$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)" \
        )
        $(call Build/Compile/PyMod,zope.interface-$(ZOPE_IF_VER), \
-               install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
-               PYTHONPATH="$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)" \
+               install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" --no-compile, \
        )
        $(SED) 's,#!$(PYTHON),#!/usr/bin/python,' $(PKG_INSTALL_DIR)/usr/bin/*
-
-       $(CP) -a \
-               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/zope.interface-*.egg/zope \
-               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/
 endef
 
 $(eval $(call PyPackage,twisted))