arm-trusted-firmware-tools: update to version 2.12
authorDaniel Golle <daniel@makrotopia.org>
Mon, 10 Feb 2025 02:28:54 +0000 (02:28 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 13 Feb 2025 03:16:40 +0000 (03:16 +0000)
Upstream changes:
 3789c3c00 build: determine toolchain tools dynamically
 ccbfd01d9 fix(tools): update the fiptool and certtool to fix POSIX build
 7c4e1eea6 build: unify verbosity handling
 10327628c Merge "feat(stm32mp2): add ddr-fw parameter for fiptool" into integration
 a11230ad0 refactor(fiptool): change all occurrences of RSS to RSE
 e494afc05 feat(stm32mp2): add ddr-fw parameter for fiptool
 ffb774212 build: use new toolchain variables for tools
 cc277de81 build: refactor toolchain detection
 503cf9927 refactor(juno): move plat_def_uuid_config to fiptool
 4d4fec281 feat(fiptool): add ability to build statically
 352366ede refactor(ethos-n): move build flags to ethosn_npu.mk
 aa57ce632 build(tools): avoid unnecessary link
 d4affdce8 Merge "fix(stm32mp1): add void entry in plat_def_toc_entries" into integration
 570a23099 fix(fiptool): move juno plat_fiptool.mk
 8214ecdab fix(stm32mp1): add void entry in plat_def_toc_entries

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/boot/arm-trusted-firmware-tools/Makefile
package/boot/arm-trusted-firmware-tools/patches/001-respect-LDFLAGS.patch
package/boot/arm-trusted-firmware-tools/patches/002-darwin_compile.patch

index 209e945a0b00c83aa66d591e7d885ffcc8702b47..dd0ed66a21f77aee6f8e392b564f569caae21b1f 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=arm-trusted-firmware-tools
-PKG_VERSION:=2.9
+PKG_VERSION:=2.12
 PKG_RELEASE:=1
-PKG_HASH:=76a66a1de0c01aeb83dfc7b72b51173fe62c6e51d6fca17cc562393117bed08b
+PKG_HASH:=b4c047493cac1152203e1ba121ae57267e4899b7bf56eb365e22a933342d31c9
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_HOST_ONLY:=1
@@ -33,7 +33,8 @@ define Host/Compile
        $(MAKE) -C \
                $(HOST_BUILD_DIR)/tools/fiptool \
                CPPFLAGS="$(HOST_CFLAGS)" \
-               LDFLAGS="$(HOST_LDFLAGS)"
+               LDFLAGS="$(HOST_LDFLAGS)" \
+               OPENSSL_DIR="$(STAGING_DIR_HOST)"
 endef
 
 define Host/Install
index 0b7989163e6f52cf9b51e95f3a5d342b8ac566c9..8959befaeb9172c40187cff9ba2772a3646dec1e 100644 (file)
@@ -1,11 +1,11 @@
 --- a/tools/fiptool/Makefile
 +++ b/tools/fiptool/Makefile
-@@ -38,7 +38,7 @@
+@@ -74,7 +74,7 @@ all: --openssl ${PROJECT}
  
  ${PROJECT}: ${OBJECTS} Makefile
-       @echo "  HOSTLD  $@"
--      ${Q}${HOSTCC} ${OBJECTS} -o $@ ${LDLIBS}
-+      ${Q}${HOSTCC} ${OBJECTS} -o $@ ${LDLIBS} $(LDFLAGS)
-       @${ECHO_BLANK_LINE}
-       @echo "Built $@ successfully"
-       @${ECHO_BLANK_LINE}
+       $(s)echo "  HOSTLD  $@"
+-      $(q)$(host-cc) ${OBJECTS} -o $@ $(LDOPTS)
++      $(q)$(host-cc) ${OBJECTS} -o $@ $(LDOPTS) $(LDFLAGS)
+       $(s)echo
+       $(s)echo "Built $@ successfully"
+       $(s)echo
index 6bc8192f442590afb56d1e55c8ad14dda1546cd1..621047a30ea175f048b63aa84ea3daea1f473466 100644 (file)
@@ -1,15 +1,6 @@
 --- a/tools/fiptool/fiptool.c
 +++ b/tools/fiptool/fiptool.c
-@@ -3,7 +3,7 @@
-  *
-  * SPDX-License-Identifier: BSD-3-Clause
-  */
--
-+#define _DARWIN_C_SOURCE
- #ifndef _MSC_VER
- #include <sys/mount.h>
- #endif
-@@ -18,6 +18,9 @@
+@@ -19,6 +19,9 @@
  #include <stdio.h>
  #include <stdlib.h>
  #include <string.h>
  
  #include "fiptool.h"
  #include "tbbr_config.h"
+--- a/tools/fiptool/fiptool_platform.h
++++ b/tools/fiptool/fiptool_platform.h
+@@ -12,6 +12,7 @@
+ #ifndef FIPTOOL_PLATFORM_H
+ #define FIPTOOL_PLATFORM_H
++#define _DARWIN_C_SOURCE
+ #ifndef _MSC_VER
+ /* Not Visual Studio, so include Posix Headers. */