ramips: use OKLI loader for TP-Link RE200 v1 and RE210 v1
authorShiji Yang <yangshiji66@qq.com>
Tue, 24 Sep 2024 10:50:01 +0000 (18:50 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 6 Oct 2024 12:07:37 +0000 (14:07 +0200)
Using OKLI image to fix the booting stuck issue.

Tested with u-boot extracted from TP-Link stock images
"RE200(EU)_V1_171206.zip" and "RE210(US_CA)_V1_171205.zip".

Fixes: https://github.com/openwrt/openwrt/issues/16296
Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Link: https://github.com/openwrt/openwrt/pull/16473
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ramips/dts/mt7620a_tplink_re2x0-v1.dtsi
target/linux/ramips/image/mt7620.mk

index 5f06dd420880eaa551264b2f50755ed88d7400a2..371b9f7373787c14be867bcaa3deffcce3602dcc 100644 (file)
@@ -4,6 +4,7 @@
 
 #include <dt-bindings/gpio/gpio.h>
 #include <dt-bindings/input/input.h>
+#include <dt-bindings/mtd/partitions/uimage.h>
 
 / {
        aliases {
                        };
 
                        partition@20000 {
-                               compatible = "tplink,firmware";
+                               compatible = "openwrt,uimage", "denx,uimage";
                                label = "firmware";
                                reg = <0x20000 0x7c0000>;
+                               openwrt,offset = <0x1000>;
+                               openwrt,ih-magic = <IH_MAGIC_OKLI>;
                        };
 
                        partition@7e0000 {
index 9f3a8dce0e35d627665072e93587733cdc24e757..6cf65ad1194bfb03d24884ff6ef284af1c48fbd4 100644 (file)
@@ -1290,7 +1290,7 @@ endef
 TARGET_DEVICES += tplink_ec220-g5-v2
 
 define Device/tplink_re200-v1
-  $(Device/tplink-v1)
+  $(Device/tplink-v1-okli)
   SOC := mt7620a
   DEVICE_MODEL := RE200
   DEVICE_VARIANT := v1
@@ -1302,7 +1302,7 @@ endef
 TARGET_DEVICES += tplink_re200-v1
 
 define Device/tplink_re210-v1
-  $(Device/tplink-v1)
+  $(Device/tplink-v1-okli)
   SOC := mt7620a
   DEVICE_MODEL := RE210
   DEVICE_VARIANT := v1